Miaomiao's Geometry

Miaomiao's Geometry


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1196    Accepted Submission(s): 21


Problem Description
  
  
There are N point on X-axis . Miaomiao would like to cover them ALL by using segments with same length. There are 2 limits: 1.A point is convered if there is a segments T , the point is the left end or the right end of T. 2.The length of the intersection of any two segments equals zero. For example , point 2 is convered by [2 , 4] and not convered by [1 , 3]. [1 , 2] and [2 , 3] are legal segments , [1 , 2] and [3 , 4] are legal segments , but [1 , 3] and [2 , 4] are not (the length of intersection doesn't equals zero), [1 , 3] and [3 , 4] are not(not the same length). Miaomiao wants to maximum the length of segements , please tell her the maximum length of segments. For your information , the point can't coincidently at the same position.
 
Input
  
  
There are several test cases. There is a number T ( T <= 50 ) on the first line which shows the number of test cases. For each test cases , there is a number N ( 3 <= N <= 50 ) on the first line. On the second line , there are N integers Ai (-1e9 <= Ai <= 1e9) shows the position of each point.
 
Output
  
  
For each test cases , output a real number shows the answser. Please output three digit after the decimal point.
 
Sample Input
  
  
3 3 1 2 3 3 1 2 4 4 1 9 100 10
 
Sample Output
  
  
1.000 2.000 8.000
Hint
For the first sample , a legal answer is [1,2] [2,3] so the length is 1. For the second sample , a legal answer is [-1,1] [2,4] so the answer is 2. For the thired sample , a legal answer is [-7,1] , [1,9] , [10,18] , [100,108] so the answer is 8.
题意:输入一组数据,保证每个数据,属于一个区间的左端点,或者右端点。并且
,每个区间不能重合,找出最大的区间长度,
分析:每个区间都可能尽可能的大,所以他们区间的最大距离就是他们之间的距离,让他们的距离按从大到小的
顺序排序,挑出,满足条件的最小数据,注意,此时最端点的两个数据不用考虑。
答案:
#include<stdio.h>
#include<string.h>
#include <algorithm>
using namespace std;
int main()
{
    int a,b,c[100010];
    double  d[100010];
    int i;
    int j;
    scanf("%d",&a);
    while(a--)
    {
        scanf("%d",&b);
        for(i=0;i<b;i++)
        scanf("%d",&c[i]);
        sort(c,c+b);//将接入的数据排序。
        for(i=1;i<b;i++)
        d[i-1]=c[i]-c[i-1];
        sort(d,d+b-1);//将差值从小到大排序。
        for(i=b-2;i>=0;i--)//从最大数据接入。
        {
            for(j=1;j<b-2;j++)
            {
                if(!((c[j]-c[j-1])>=d[i]||(c[j+1]-c[j]>=d[i])))//只要接入的数据比前面的
                                                //大或者比后面的小d【i】,就满足条件。
                   break;

            }
            if(j==b-2)
             {printf("%.3f\n",d[i]);
            break;}
        }

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值