POJ 2083 Fractal

C - Fractal(3.4.1)
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u

 

Description

A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales.  
A box fractal is defined as below :  
  • A box fractal of degree 1 is simply 

  • A box fractal of degree 2 is 
    X X 

    X X 
  • If using B(n - 1) to represent the box fractal of degree n - 1, then a box fractal of degree n is defined recursively as following 
    B(n - 1)        B(n - 1)
    
            B(n - 1)
    
    B(n - 1)        B(n - 1)

Your task is to draw a box fractal of degree n.

Input

The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer −1 indicating the end of input.

Output

For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case.

Sample Input

1
2
3
4
-1

Sample Output

X
-
X X
 X
X X
-
X X   X X
 X     X
X X   X X
   X X
    X
   X X
X X   X X
 X     X
X X   X X
-
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
         X X   X X
          X     X
         X X   X X
            X X
             X
            X X
         X X   X X
          X     X
         X X   X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
-


 

#include <iostream>
using namespace std;
char map[1000][1000];
void print(int n,int x,int y)
{
	int m=1;
	if(n==1)
	{
		map[x][y]='X';
		return;
	}
	else if(n>1)
	{
		int i;
		for(i=0;i<n-2;i++)
			m=m*3;
		print(n-1,x, y);
		print(n-1,x, y+2*m);
		print(n-1,x+m, y+m);
		print(n-1,x+2*m, y);
		print(n-1,x+2*m, y+2*m);
	}
}

int main()
{
	int n;
	while(cin>>n&&n!=-1)
	{
		int i,j;
		int len=1;
		for(i=0;i<n-1;i++)
			len=len*3;
		for(i=0;i<len;i++)
			for(j=0;j<len;j++)
				map[i][j]=' ';
			print(n,0,0);
			for(i=0;i<len;i++)
			{
				for(j=0;j<len;j++)
					cout<<map[i][j];
				cout<<endl;
			}
			cout<<"-"<<endl;
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值