POJ 2080 Calendar

Description

A calendar is a system for measuring time, from hours and minutes, to months and days, and finally to years and centuries. The terms of hour, day, month, year and century are all units of time measurements of a calender system.
According to the Gregorian calendar, which is the civil calendar in use today, years evenly divisible by 4 are leap years, with the exception of centurial years that are not evenly divisible by 400. Therefore, the years 1700, 1800, 1900 and 2100 are not leap years, but 1600, 2000, and 2400 are leap years.
Given the number of days that have elapsed since January 1, 2000 A.D, your mission is to find the date and the day of the week.

Input

The input consists of lines each containing a positive integer, which is the number of days that have elapsed since January 1, 2000 A.D. The last line contains an integer −1, which should not be processed.
You may assume that the resulting date won’t be after the year 9999.

Output

For each test case, output one line containing the date and the day of the week in the format of "YYYY-MM-DD DayOfWeek", where "DayOfWeek" must be one of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" and "Saturday".

Sample Input

1730
1740
1750
1751
-1

Sample Output

2004-09-26 Sunday
2004-10-06 Wednesday
2004-10-16 Saturday
2004-10-17 Sunday

 

题目大意:

给定公元2000-1-1后的天数,计算这一天是哪年哪月哪日星期几。


刚开始做的时候发现自己在用很笨的方法。。

#include <iostream>
#include <stdio.h>
using namespace std;
int main()
{
    int n;
    while(cin>>n&&n!=-1)
	{
		int year;
		int sum1=0;
		for(year=2000;;year++)
		{
			if(year%4==0&&year%100!=0||year%400==0)
			{
				sum1=sum1+366;
				if(sum1>=n)
				{
					sum1=sum1-366;
					break;
				}
			}
			else
			{sum1=sum1+365;
			if(sum1>=n)
			{
				sum1=sum1-365;
				break;
			}
			}
		}
		int sum=0;
		sum=n-sum1;
		int month;
		int sum2=0;
		int sum3=0;
		for(month=1;month<=12;month++)
		{
			if(month==1||month==3||month==5||month==7||month==8||month==10||month==12)
			{
				sum2=sum2+31;
				if(sum2>=sum)
				{
					if(sum2>sum)
					{
						sum2=sum2-31;
						break;
					}
					else
					{
						if(month==12)
						{year=year+1;
						month=1;
						break;
						}
						else
						{
						month=month+1;
						break;
						}
					}
				}
			}
			else if(month==4||month==6||month==9||month==11)
			{
				sum2=sum2+30;
				if(sum2>=sum)
				{
					if(sum2>sum)
					{
						sum2=sum2-30;
						break;
					}
					else
					{
						month=month+1;
						break;
					}
				}
			}
			
			else
			{
				if(year%4==0&&year%100!=0||year%400==0)
				{
					sum2=sum2+29;
					if(sum2>=sum)
					{
						if(sum2>sum)						
						{
							sum2=sum2-29;
							break;
						}
						else
						{
						month=month+1;
						break;
						}
					}
				}
				else
				{
					sum2=sum2+28;
					if(sum2>=sum)
					{
						if(sum2>sum)
						{
							sum2=sum2-28;
							break;
						}
						else
						{
						if(month==12)
						{year=year+1;
						month=1;
						break;
						}
						else
						{
						month=month+1;
						break;
						}
						}
					}
				}
				
			}
			
		}
		sum3=sum-sum2;
		cout<<year<<"-";
		printf("%02d-",month);
		printf("%02d ",sum3+1);
		int s;
		s=n%7;
		switch(s)
		{
		case(0):cout<<"Saturday"<<endl;break;
		case(1):cout<<"Sunday"<<endl;break;
		case(2):cout<<"Monday"<<endl;break;
		case(3):cout<<"Tuesday"<<endl;break;
		case(4):cout<<"Wednesday"<<endl;break;
		case(5):cout<<"Thursday"<<endl;break;
		case(6):cout<<"Friday"<<endl;break;
		}
	}
    return 0;
}


后来,发现还有非常简单的方法。。

#include <stdio.h>
#include<string.h>
#include<math.h>

char week[7][10]={"Saturday","Sunday","Monday","Tuesday","Wednesday","Thursday","Friday"};
int year[2]={365,366};
int month[2][12]={31,28,31,30,31,30,31,31,30,31,30,31,31,29,31,30,31,30,31,31,30,31,30,31};
int type(int m)
{
    if(m%4!=0||(m%100==0&&m%400!=0))
        return 0;
    else return 1;
}
int main()
{
    int days,dayofweek;
    int i=0,j=0;
    while(scanf("%d",&days)!=EOF&&days!=-1)
    {
        dayofweek=days%7;
        for(i=2000;days>=year[type(i)];i++)
            days-=year[type(i)];
        for(j=0;days>=month[type(i)][j];j++)
            days-=month[type(i)][j];
        printf("%d-%02d-%02d %s\n",i,j+1,days+1,week[dayofweek]);
    }
    return 0;
}

这就是差距啊。。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值