UVA 10008 What's Cryptanalysis?

E - What's Cryptanalysis?
Crawling in process... Crawling failed
Time Limit: 3000MS     Memory Limit: 0KB     64bit IO Format: %lld & %llu

Description

Cryptanalysis is the process of breaking someone else's cryptographic writing. This sometimes involves some kind of statistical analysis of a passage of (encrypted) text. Your task is to write a program which performs a simple analysis of a given text.

Input

The first line of input contains a single positive decimal integer n. This is the number of lines which follow in the input. The next n lines will contain zero or more characters (possibly including whitespace). This is the text which must be analyzed.

Output

Each line of output contains a single uppercase letter, followed by a single space, then followed by a positive decimal integer. The integer indicates how many times the corresponding letter appears in the input text. Upper and lower case letters in the input are to be considered the same. No other characters must be counted. The output must be sorted in descending count order; that is, the most frequent letter is on the first output line, and the last line of output indicates the least frequent letter. If two letters have the same frequency, then the letter which comes first in the alphabet must appear first in the output. If a letter does not appear in the text, then that letter must not appear in the output.

Sample Input

3
This is a test.
Count me 1 2 3 4 5.
Wow!!!!  Is this question easy?

Sample Output

S 7
T 6
I 5
E 4
O 3
A 2
H 2
N 2
U 2
W 2
C 1
M 1
Q 1
Y 1


#include <iostream>
#include <string>
#include <string.h>
#include <stdio.h>
using namespace std;
int main()
{
    char str[1005];
    int n;
    cin>>n;
    int i,j;
    int a[26];
    memset(a,0,sizeof(a));
	getchar();
    for(i=1;i<=n;i++)
    {
        gets(str);
        int j;
        int len;
        len=strlen(str);
        for(j=0;j<len;j++)
			if(str[j]>='a'&&str[j]<='z'||str[j]>='A'&&str[j]<='Z')
				a[tolower(str[j])-'a']+=1;
    }
	char m;
	
    for(i=0;i<26;i++)
	{   
		int max=0;
		for(j=0;j<26;j++)
		{
			if(a[j]>max)
			{
				m=j+'A';
				max=a[j];
			}
		}
		for(j=0;j<26;j++)
		{
			if(max==a[j])
			{
				a[j]=-1;
				if(max==0)
					break;
				else
				{
					cout<<m<<" "<<max<<endl;
					break;
				}
			}
		}
		
	}
	
	
    return 0;
}
/*
3
This is a test.
Count me 1 2 3 4 5.
Wow!!!!  Is this question easy?
*/






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值