HDU - 2141 Can you find it?

Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X. 
 

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers. 
 

Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO". 
 

Sample Input

    
    
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output

    
    
Case 1: NO YES

NO

题解:简单二分,首先可把任意两组相加,后得到n*l或者n*m或者l*m的一维数组,排序后,用二分搜索大的一维和例外一组数据相加比较是否等于给出S数据。

#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;

int L[510],N[510],M[510];
int num[250100];

//测试输出
void print(int a[],int len){
    for(int i = 0 ; i < len; i++)cout<<a[i]<<" ";
}

int main(){
    int l,n,m,p,time = 0;
    while(scanf("%d%d%d",&l,&n,&m) == 3){
        for(int i = 0; i < l; i++)scanf("%d",&L[i]);
        for(int j = 0; j < n; j++)scanf("%d",&N[j]);
        for(int k = 0; k < m; k++)scanf("%d",&M[k]);
        p = 0;
        for(int i = 0; i < l; i++) // 任意两数组相加
            for(int j = 0; j < n; j++)
                num[p++] = L[i]+N[j];
        sort(num,num+p); //用二分搜索,先排序
        int T;
        printf("Case %d:\n",++time);
        scanf("%d",&T);
        while(T--){
            int s;
            scanf("%d",&s);
            bool flag = false;
            for(int i = 0; i < m;i++){
                int low = 0,high = p-1,mid = 0;
                while(low<=high){ //利用二分搜索相同s
                    mid = (low+high)>>1;
                    if(num[mid]+M[i] == s){flag = true;break;}
                    if(num[mid]+M[i] > s) high = mid - 1;
                    else low = mid + 1;
                }
                if(flag == true)break;
            }
            flag ? printf("YES\n"):printf("NO\n");
        }
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值