hdu-2141 can you find it(二分查找)

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 17976    Accepted Submission(s): 4538


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
 

//hdu-2141 can you find it?(二分查找)
//题目大意:
//给你三组数,当输入一个数x时,从这三组数任意选三个数a[i],b[j],c[k];判断x是否等于a[i],b[j],c[k]三者之和;
//若是,输出YES,否则,输出NO;
//解题思路;
// 定义三个数组a[],b[],c[]用来存放这三组数;主要思路是先将前两个数组的数相加合成一个数组d[];
//然后用二分在d[]数组里查找x-c[k];若能找到一个数c[k]使得x-c[k]=d[mid]=a[i]+b[j];打印YES,否则,打印NO. 
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
	int l,n,m,s,d[250010],x,flag;
	int a[510],b[510],c[510];             //定义三个数组,分别存放三组数; 
	int i,j,ca=1,k,len,left,right,mid;
	while(scanf("%d%d%d",&l,&n,&m)!=EOF)
	{
		len=0;
		for(i=0;i<l;i++)
		 scanf("%d",&a[i]);
		for(i=0;i<n;i++)
		 scanf("%d",&b[i]);
		for(i=0;i<m;i++)
		 scanf("%d",&c[i]);
		for(i=0;i<l;i++)                //将前两个数组合为一个数组并排序; 
		 for(j=0;j<n;j++)
		   d[len++]=a[i]+b[j];
		sort(d,d+len);
		scanf("%d",&s);
		printf("Case %d:\n",ca++);
	    while(s--)
	    {
	    	k=0;
	    	flag=0;
	    	scanf("%d",&x);
	    	for(i=0;i<m;i++)             //二分查找 
	    	{
	    	   if(k) 
			    break;
			   left=0,right=len-1;
	    	   while(left<=right)
	    	   {
	    	  	mid=(left+right)/2;
	    	   	if(d[mid]>x-c[i]) 
	    	   	  right=mid-1;
	    	   	else if(d[mid]<x-c[i])
	    	   	  left=mid+1;
	    	   	else if(d[mid]==x-c[i])
	    	   	{
	    	   		k=1;
	    	   		break;
				}
			   }
			}
		if(k)
		 printf("YES\n");
		else
		 printf("NO\n");
		}
	}
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值