poj2608

Soundex
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9385 Accepted: 4656

Description

Soundex coding groups together words that appear to sound alike based on their spelling. For example, "can" and "khawn", "con" and "gone" would be equivalent under Soundex coding. 
Soundex coding involves translating each word into a series of digits in which each digit represents a letter: 
      1 represents B, F, P, or V

      2 represents C, G, J, K, Q, S, X,  or Z

      3 represents D or T

      4 represents L

      5 represents M or N

      6 represents R

The letters A, E, I, O, U, H, W, and Y are not represented in Soundex coding, and repeated letters with the same code digit are represented by a single instance of that digit. Words with the same Soundex coding are considered equivalent.

Input

Each line of input contains a single word, all upper case, less than 20 letters long.

Output

For each line of input, produce a line of output giving the Soundex code. 

Sample Input

KHAWN
PFISTER
BOBBY

Sample Output

25
1236
11
源代码:
#include<iostream>
using namespace std;


int kan(char a)
{
    if(a=='B'||a=='F'||a=='P'||a=='V') return 1;
    if(a=='C'||a=='G'||a=='J'||a=='K'||a=='Q'||a=='S'||a=='X'||a=='Z') return 2;
    if(a=='D'||a=='T') return 3;
    if(a=='L') return 4;
    if(a=='M'||a=='N') return 5;
    if(a=='R') return 6;
    else return 0;
}
int main()
{
	char a[21];
	int i,now,last;
    while(scanf("%s",a)!=EOF)
    {
        int l=strlen(a);
        for(i=0,now=0,last=0;l-i;i++)
        {
            now=kan(a[i]);
            if(now!=0 && now!=last)
            {
                cout<<now;
            }
            last=now;
        }
        cout<<endl;
    }
	return 0;
}
这是一道输入字母然后按照他的规则输出数字的题目,但是连续的2个同样的字母不能输入2次,一开始我是全部判断出来存在一个数组里,而且把不存在的情况都去掉了,所以死活不能消去。后来参考了discuss里大神的代码,就用函数判断再直接输出,简洁方便。本题看起来简单,但是做起来烦的要命,许多细节要注意,再次po上代码,供大家批判。。。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值