Hdu1358 Period、KMP、循环节:【题解】

Period

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K

Problem Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1

2 2
3 3

Test case #2

2 2
6 2
9 3
12 4

题目大意:小声哔哔:这个题的题目甚至样例读起来都有点拗口,光题目就看了好久,输入p串的长度l,从0开始到第n个字符,这n - 1个字符串的前缀最多循环了多少次,输出n和周期。
	这个题目需要找一下规律,nxt[ i ]和其对应下标 i + 1;
	if((i + 1) % (i+1 - nxt[i]) == 0 && nxt[i]) 
		printf("%d %d\n", i+1, (i + 1) / (i+1 - nxt[i]));

这里: (i+1 - nxt[i]) 是循环节的长度,if语句中:如果长度是循环节的倍数且公共前后缀不为0,说明这个从头到 i + 1 满足题意,输出n和周期即可。
这篇文章介绍了next数组的最小循环节

AC代码如下:

#include <iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
using namespace std;
char t[1000005];
char p[1000005];
int nxt[1000005];
//建立公共前后缀表, /*****next[j] = k 代表p[j] 之前的模式串子串中,有长度为k 的相同前缀和后缀*****/
void GetNext(char p[], int nxt[]){	// 
	int i, j;
	int m = strlen(p);
	nxt[0] = 0;
	for(j = 1, i = 0; j < m; j++){	//前缀 i,从0开始 后缀j,从1开始 
		while(i > 0 && p[j] != p[i])
			i = nxt[i-1];
		if(p[j] == p[i]){			//前后匹配时,next就加一 
			i++;
		}
		nxt[j] = i;	//①p[j] != p[i] && i == 0,赋值0
					//②p[j] == p[i] && i == 0,i已经加一(i在原匹配串上增加) 
	}				//③p[j] == p[i] && i != 0,回溯过后,给值为第一次匹配的后一位 
} 
int main(){
	int l, count = 1;
	while(scanf("%d", &l) != EOF && l){
		scanf("%s", p);
	int n = strlen(p);
	GetNext(p, nxt);
	printf("Test case #%d\n", count++);
	for(int i = 1; i < n; i++){
		if((i + 1) % (i+1 - nxt[i]) == 0 && nxt[i]) 
			printf("%d %d\n", i+1, (i + 1) / (i+1 - nxt[i]));
	}
	printf("\n");
	}	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值