POJ 1979 Red and Black 基础性的DFS

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45

59

6

13


题意:以‘@’为起始点,找出所有能到达的‘.’的个数,‘#’视为墙,不可走。(‘@’本身也算‘.’)

思路:见代码

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

const int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
char map[30][30];
bool vis[30][30];
int w,h,sum;
int kx,ky;

void dfs(int kx,int ky)
{
    for(int i = 0; i < 4; i++)//搜索点的四个方向
    {
        int tx = kx + dir[i][0];
        int ty = ky + dir[i][1];
        if(!vis[tx][ty])//搜索到一个‘.’ , 进行记录并以该点为起始点继续深搜
        {
            vis[tx][ty] = 1;//把搜索出来的‘.’记录,防止重复计算
            sum++;
            dfs(tx,ty);
        }
    }
}

int main( )
{
    while(cin>>w>>h&&w&&h)
    {
        getchar();
        memset(vis,1,sizeof(vis));//把vis初始化为1,可无需设置边界,
        for(int i = 1; i <= h; i++)
        {
            for(int j = 1; j <= w; j++)
            {
                cin>>map[i][j];
                if('@'==map[i][j])
                {
                    kx = i;
                    ky = j;
                }
                else if('.'==map[i][j])
                {
                    vis[i][j]=0;//输入的‘.’记录为0,意为可走
                }
            }
            getchar();
        }
        sum = 1;
        dfs(kx,ky);
        cout<<sum<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值