POJ 2352 & HDU 1541 Stars ( 树状数组)

Stars

Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.





题意:如题中的图给出各星星的位置关系,题意是每个星星都有一个等级,每个星星的等级就等于这颗星星左下方的星星个数。然后给你好多星星的坐标,让你求出每个等级上的星星个数。


心得:开始没怎么仔细看题,以至于连题目啥意思都没看懂,再次暴露了英语实力啊。。。后来又一遍一遍的看才看懂啥意思,然后就按树状数组敲呗,一交TLE。。。后来再一看题,才发现,想多了,忽略了题目中的依据关键的话,已经标出:所有星星已经先按其纵坐标,纵坐标相等时再按其横坐标从小到大排好了序,就是输入的时候, 是按各星星的坐标排好的序。这样就简单了啊!!!


分析:由于星星已经按坐标排好了序,那就不需要再对星星坐标排序了,这样排在前面的星星总是在后面星星的左下方,这样只需要把前面的点的个数求出来即可。

      实现这个目标只需在每次加入星星时,令add(int x,int d)里的d为1即可,每次加的都是1,这样sum()的值就是该星星的等级了,再开个数组记录一下即可。


PS:还要注意的是,x可能为0,故在加入和查询的时候都是x+1.




AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
#define INF 0x7fffffff
using namespace std;
const int maxn = 15000 + 10;
const int maxx = 32000 + 10;
int c[maxx],cnt[maxn];

int lowbit(int x)
{
    return x & (-x);
}

int sum(int x)
{
    int ret = 0;
    while(x > 0)
    {
        ret += c[x];
        x -= lowbit(x);
    }
    return ret;
}

void add(int x,int d)
{
    while(x <= maxx)
    {
        c[x] += d;
        x += lowbit(x);
    }
}

int main()
{
    int n,x,y;
    while(scanf("%d",&n)!=EOF)
    {
        memset(c,0,sizeof(c));
        memset(cnt,0,sizeof(cnt));
        for(int i=0; i<n;i++)
        {
            scanf("%d%d",&x,&y);
            int temp = sum(x+1);      //sum()即为星星的等级
            cnt[temp]++;
            add(x+1,1);               //加入x+1,且d为1                  
        }
        for(int i=0; i<n; i++)
            printf("%d\n",cnt[i]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值