HDU 1159 & POJ 1458 Common Subsequence (LCS)

Common Subsequence

Time Limit:1000MS    Memory Limit:10000KB    64bit IO Format:%I64d & %I64u

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, x ij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0



题意:给你两个字符串s1,s2,求两个字符串的最长公共子序列的长度。


心得:这是个技术活,凭空想当然想不出来,只好从书上借鉴了一些。。。


分析:纯裸的最长公共子序列,不解释。。。总体思想是DP,直接搞,开个二维数组dp,从两个字符串的开头往后扫,dp[i][j]代表s1扫s1[i]位置、s2扫到s2[j]位置时的最长公共子序列的长度,dp[i][j] = max( dp[i-1][j] , dp[i][j-1] ) ,且当s1[i-1] == s2[j] 时,dp[i][j] = max( dp[i][j] , dp[i-1][j-1] +1) .






AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
#define INF 0x7fffffff
using namespace std;
const int maxn = 1000 + 10;
string a,b;
int dp[maxn][maxn];

int LCS(int n1, int n2, string c, string d)
{
    for(int i = 1; i <= n1; i++)
        for(int j = 1; j <= n2; j++)
        {
            dp[i][j] = max(dp[i-1][j], dp[i][j-1]);
            if(c[i-1] == d[j-1] && dp[i-1][j-1] + 1 > dp[i][j])
                dp[i][j] = dp[i-1][j-1] + 1;
        }
    return dp[n1][n2];
}

int main()
{
    while(cin>>a>>b)
    {
        memset(dp,0,sizeof(dp));            //初始化dp数组
        cout<<LCS(a.size(),b.size(),a,b)<<endl;    
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值