POJ-1459-Power Network(网络流 EK)

Power Network

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6



输入分别为n个点,np个发电站,nc个用户,m条边;

接下去是m条边的信息(u,v)cost,cost表示边(u,v)的最大流量;

np个发电站的信息(u)cost,cost表示发电站u能提供的最大流量;

nc个用户的信息(v)cost,cost表示每个用户v能接受的最大流量。

典型的最大网络流中多源多汇的问题,在图中添加1个源点S和汇点T,

将S和每个发电站相连,边的权值是发电站能提供的最大流量;

将每个用户和T相连,边的权值是每个用户能接受的最大流量。

从而转化成了一般的最大网络流问题,然后求解。





#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <queue>
using namespace std;
const int inf = 1e8;

int cap[1000][1000],a[1000],flow[1000][1000],pre[1000];
int maxflow;
int n,np,nc,m;

void E_K ()
{
    queue <int >q;
    memset (flow,0,sizeof (flow));
    while (1)
    {
        memset (a,0,sizeof (a));
        pre[0] = -1;
        a[0] = inf;
        q.push (0);
        while (!q.empty())
        {
            int u = q.front();
            q.pop ();
            for (int v = 0; v <= n + 1; v++)
            {
                if ( !a[v] && cap[u][v] > flow[u][v])
                {
                    q.push (v);
                    pre[v] = u;

                    a[v] = min (a[u],cap[u][v] - flow[u][v]);//1-->v的最小残量

                }
            }
        }

        if ( a[n + 1] == 0)//找不到
            break;
        maxflow += a[n + 1];
        for (int v = n + 1; v != -1 ; v = pre[v])
        {
            flow[pre[v]][v] += a[n + 1];///正向加
            flow[v][pre[v]] -= a[n + 1];///反向减
        }
    }
    printf ("%d\n",maxflow);
}

int main ()
{
    int u,v,z;
    while (~scanf ("%d%d%d%d",&n,&np,&nc,&m))
    {
        maxflow = 0;
        memset (cap,0,sizeof (cap));
        while (m --)
        {
            scanf (" (%d,%d)%d",&u,&v,&z);
            cap[u + 1][v + 1] = z;
        }
        while (np--)
        {
            scanf (" (%d)%d",&u,&z);
            cap[0][u + 1] = z;
        }
        while (nc--)
        {
            scanf (" (%d)%d",&u,&z);
            cap[u + 1][n + 1] = z;
        }
        E_K ();
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值