POJ-1459 Power Network

Power Network
题目链接
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 29776 Accepted: 15423
Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount 0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.

An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.
Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.
Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.
Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
(0)5 (1)2 (3)2 (4)1 (5)4
Sample Output

15
6
Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.
Source

Southeastern Europe 2003

题目大意

给你n个点,m条边,被条边有最大输电量,n个点中,有nx个发电站(有最大发电量),有ny个是收点站(有最大收电量,且不会与发电站共点)。求能收到的最大电量。
(nx,ny<=n<=100,m<=n^2,边的容量<=1000)

题解
典型的网络流求最大流。由于存在多个源,我们可以构造一个超级源,数据较小接下来正常刷EK就好了。

代码

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=105;
int n,m,nx,ny,V[maxn][maxn],lst[maxn],low[maxn],q[maxn],til,hea,ans;
int read()
{
    int ret=0,f=1;char ch=getchar();
    while (ch<'0'||ch>'9') {if (ch=='-') f=-1;ch=getchar();}
    while (ch>='0'&&ch<='9') ret=ret*10+ch-'0',ch=getchar();
    return ret*f;
}
void EK()
{
    ans=0;//多组数据,记得清干净
    while (1)
    {
        memset(low,0,sizeof low);
        memset(lst,255,sizeof lst);
        low[n+1]=1e9;//low[i]表示走到i点的最大流
        q[til=1]=n+1;hea=0;
        while (hea!=til)
        {
            int x=q[(++hea)%=maxn];
            for (int i=0;i<=n+2;i++)
              if (!low[i]&&0<V[x][i])
              {
                  low[i]=min(V[x][i],low[x]);
                  lst[i]=x;q[(++til)%=maxn]=i;
              }
        }
        if (low[n+2]==0) break;//如果不存在增广路……
        int sum=low[n+2];ans+=sum;
        for (int i=n+2;~lst[i];i=lst[i])
          V[lst[i]][i]-=sum,V[i][lst[i]]+=sum;//修正剩余容量
    }
}
int main()
{
    while (~scanf("%d",&n))
    {
        nx=read(),ny=read(),m=read();
        memset(V,0,sizeof V);
        for (int i=1,x,y;i<=m;i++) x=read(),y=read(),V[x][y]+=read();
        for (int i=1,y;i<=nx;i++) y=read(),V[n+1][y]+=read();//n+1为源
        for (int i=1,x;i<=ny;i++) x=read(),V[x][n+2]+=read();//n+2为汇
        EK();printf("%d\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值