Highways(最小生成树_prim()求最短路中的最大路径)


Highways
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22867 Accepted: 10540

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692
 
 
题意:其实就是求最小生成树中的最大路径;
第一行T指有几组测试数据,接下来n是有几个村子,接下来n行是指从1号到n号距离每个村子的距离,比如(0,990,692)指的是一号村子距离一号村子的距离为0,距离二号位990,距离三号为692.
 
 
 
 
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
using namespace std;
#define inf 0x3f3f3f
int map[505][505];
int dis[505];
int vis[505];
int n;
void prim()
{
    int i,j,k;
    int sum=0;
    int max=-1;
    int min;
    memset(vis,0,sizeof(vis));
    for(i=1; i<=n; i++)
        dis[i]=map[1][i];
    vis[1]=1;
    for(i=1; i<n; i++)
    {
        min=inf;
        for(j=1; j<=n; j++)
            if(!vis[j]&&dis[j]<min)
            {
                min=dis[j];
                k=j;
            }
        vis[k]=1;
        if(max<min)
            max=min;
        for(j=1; j<=n; j++)
        {
            if(!vis[j]&&map[k][j]<dis[j])
            {
                dis[j]=map[k][j];
            }
        }
    }
    printf("%d\n",max);
}
int main()
{
    int T;
    int i,j,w;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
            {
                if(i==j)
                    map[i][j]=0;
                else
                    map[i][j]=inf;
            }
        for(i=1; i<=n; i++)
            for(j=1; j<=n; j++)
            {
                scanf("%d",&w);
                map[i][j]=min(map[i][j],w);
            }
        prim();
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值