POJ 3267-The Cow Lexicon(dp_字符串)

17 篇文章 0 订阅

The Cow Lexicon
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8341 Accepted: 3941

Description

Few know that the cows have their own dictionary with W (1 ≤ W ≤ 600) words, each containing no more 25 of the characters 'a'..'z'. Their cowmunication system, based on mooing, is not very accurate; sometimes they hear words that do not make any sense. For instance, Bessie once received a message that said "browndcodw". As it turns out, the intended message was "browncow" and the two letter "d"s were noise from other parts of the barnyard.

The cows want you to help them decipher a received message (also containing only characters in the range 'a'..'z') of length L (2 ≤ L ≤ 300) characters that is a bit garbled. In particular, they know that the message has some extra letters, and they want you to determine the smallest number of letters that must be removed to make the message a sequence of words from the dictionary.

Input

Line 1: Two space-separated integers, respectively:  W and  L 
Line 2:  L characters (followed by a newline, of course): the received message 
Lines 3.. W+2: The cows' dictionary, one word per line

Output

Line 1: a single integer that is the smallest number of characters that need to be removed to make the message a sequence of dictionary words.

Sample Input

6 10
browndcodw
cow
milk
white
black
brown
farmer

Sample Output

2

题意:一本字典有w了单词,有一个长度为L的字符串,问最少删减多少个才能让她的组成全部为字典里的单词。

思路:设置dp[i]为前i个单词删除的字母个数,则状态转移方程为dp[i]=min(dp[i],dp[pos+1]+i-1-pos-k);

例如:browndcodw

                          co  w找到一个匹配,并且删掉一个字母,所以状态可以从dp[6]转移来的。


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <queue>

using namespace std;
const int inf=0x3f3f3f3f;
char str[610][30];
char a[310];
int dp[310];

int main()
{
    int w,l,i,j;
    while(~scanf("%d %d",&w,&l)){
        scanf("%s",a);
        for(i=0;i<w;i++)
            scanf("%s",str[i]);
        dp[0]=0;
        for(i=1;i<=l;i++){
            dp[i]=dp[i-1]+1;
            for(j=0;j<w;j++){
                int pos=i-1;
                int cnt=strlen(str[j])-1;
                int k=strlen(str[j]);
                while(pos>=0&&cnt>=0){
                    if(a[pos]==str[j][cnt])
                        cnt--;
                    pos--;
                }
                if(cnt<0)//代表有一个单词匹配完
                    dp[i]=min(dp[i],dp[pos+1]+i-1-pos-k);
            }
        }
         printf("%d\n",dp[l]);
        }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值