Catch That Cow

题目链接:http://poj.org/problem?id=3278

Catch That Cow

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 46146 Accepted: 14467

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题目描述:数轴上两个点N,K,从N点出发,若当前处于i位置,则下次只能走到i+1或i-1或2*i,求到达K点的最短路径。思路:BFS,遍历每一层节点,同时记录到达该点的距离,代码如下:

#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>
#define M 100000+10
using namespace std;
bool vis[M];//标记是否已经访问过
int st[M];//保存到节点的距离
int bfs(int N,int K)
{
    memset(st,0,sizeof(st));
    memset(vis,0,sizeof(vis));
    if(N==K)return 0;
    queue<int>q;
    int t;
    q.push(N);
    while(!q.empty())
    {
        t=q.front();
        q.pop();
        if(t+1<=M&&!vis[t+1])
        {
            vis[t+1]=1;
            st[t+1]=st[t]+1;
            q.push(t+1);
        }
        if(t+1==K)break;
        if(t-1>=0&&!vis[t-1])
        {
            vis[t-1]=1;
            st[t-1]=st[t]+1;
            q.push(t-1);
        }
        if(t-1==K)break;
        if((t<<1)<=M&&!vis[t<<1])
        {
            vis[t<<1]=1;
            st[t<<1]=st[t]+1;
            q.push(t<<1);
        }
        if(t<<1==K)break;
    }
    return st[K];
}
int main()
{
    int N,K;
    cin>>N>>K;
    cout<<bfs(N,K)<<endl;
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值