题目链接:http://poj.org/problem?id=3278
Catch That Cow
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 46146 | Accepted: 14467 |
Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
Input
Output
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
题目描述:数轴上两个点N,K,从N点出发,若当前处于i位置,则下次只能走到i+1或i-1或2*i,求到达K点的最短路径。思路:BFS,遍历每一层节点,同时记录到达该点的距离,代码如下:
#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>
#define M 100000+10
using namespace std;
bool vis[M];//标记是否已经访问过
int st[M];//保存到节点的距离
int bfs(int N,int K)
{
memset(st,0,sizeof(st));
memset(vis,0,sizeof(vis));
if(N==K)return 0;
queue<int>q;
int t;
q.push(N);
while(!q.empty())
{
t=q.front();
q.pop();
if(t+1<=M&&!vis[t+1])
{
vis[t+1]=1;
st[t+1]=st[t]+1;
q.push(t+1);
}
if(t+1==K)break;
if(t-1>=0&&!vis[t-1])
{
vis[t-1]=1;
st[t-1]=st[t]+1;
q.push(t-1);
}
if(t-1==K)break;
if((t<<1)<=M&&!vis[t<<1])
{
vis[t<<1]=1;
st[t<<1]=st[t]+1;
q.push(t<<1);
}
if(t<<1==K)break;
}
return st[K];
}
int main()
{
int N,K;
cin>>N>>K;
cout<<bfs(N,K)<<endl;
return 0;
}