Girls and Boys

Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.       

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:       

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...       
or
student_identifier:(0)       

The student_identifier is an integer number between 0 and n-1, for n subjects.       
For each given data set, the program should write to standard output a line containing the result.       
              

Input

输入数据的第一行是三个整数K , M , N,分别表示可能的组合数目,女生的人数,男生的人数。0<K<=1000
1<=N 和M<=500.接下来的K行,每行有两个数,分别表示女生Ai愿意和男生Bj做partner。最后一个0结束输入。      
       

Output

对于每组数据,输出一个整数,表示可以坐上过山车的最多组合数。      
       

 

Sample Input

    
    
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
              

Sample Output

    
    
5 2

 

 题意:求最大独立集,有n个男女生,知道其中的和其他有关系,求集合中全是两两无关的最大集合

因为没有明显的男女,只需要假设都是n最后再除于2就可以了

二分图最大独立集=顶点数-二分图最大匹配

//先贪心,加入贪心之后未找到未匹配点,则说明已经是最优的,否则则从贪心的基础上DFS进行更新
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
using namespace std;
int n,m;
int map[1100][1100];
int flag[1100];//y节点标记
int vist[1100];//与Y节点相交的x节点
void init()
{
    memset(map,0,sizeof(map));
    memset(vist,-1,sizeof(vist));
}
int find(int i)
{
    int j;
    for(j=0; j<n; j++)
    {
        if(map[i][j]&&!flag[j])
        {
            flag[j]=1;
            if(vist[j]==-1||find(vist[j]))
            {
                vist[j]=i;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int i,j,k;
    int x,y,a;
    int count;
    while(~scanf("%d",&n))
    {
        init();
        for(i=0; i<n; i++)
        {
            scanf("%d: (%d)",&a,&m);
            for(j=0; j<m; j++)
            {
                scanf("%d",&x);
                map[a][x]=1;
            }
        }
        count=0;
        for(i=0; i<n; i++)
        {
            memset(flag,0,sizeof(flag));
            if(find(i))
                count++;
        }
        printf("%d\n",n-count/2);//二分图最大独立集=顶点数-二分图最大匹配
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值