hdu1015 dfs 回溯

给你一个目标数,再给一个由大写字母构成的字符串,规模是5-12个大写字母。
从里面选5个字母v,m,x,y,z,计算v-m^2+x^3-y^4+z^4是否等于目标值
选出来的方案可能有很多种,那么你应该选择字典序最大的那种。

我得到这个题主要是没看清楚题目:给出的字母有没有重复的,我写成没有重复的情况,所以测试数据一直过,提交就wa

Safecracker
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10579 Accepted Submission(s): 5408

Problem Description
=== Op tech briefing, 2002/11/02 06:42 CST ===
“The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein’s secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, …, Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary.”

v - w^2 + x^3 - y^4 + z^5 = target

“For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn’t exist then.”

=== Op tech directive, computer division, 2002/11/02 12:30 CST ===

“Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or ‘no solution’ if there is no correct combination. Use the exact format shown below.”

Sample Input

1 ABCDEFGHIJKL
11700519 ZAYEXIWOVU
3072997 SOUGHT
1234567 THEQUICKFROG
0 END

Sample Output

LKEBA
YOXUZ
GHOST
no solution

上代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#define maxn 26

#define res(v,w,x,y,z) v-w*w+x*x*x-y*y*y*y+z*z*z*z*z
using namespace std;
bool isvisited[maxn];
long long target;
char str[maxn];
int l[26];

bool cmp(char a,char b){
    return !(a<b);
}


//深搜枚举
bool dfs( int k){
    if(k==5){
        long long temp=res(l[0],l[1],l[2],l[3],l[4]);
            if(temp==target)
                return true;
        return false;
    }
    else{
        for(int i=0;i<strlen(str);i++){
            if(isvisited[i]==false){
                isvisited[i]=true;
                l[k]=str[i];
                if(dfs(k+1)) return true;
                isvisited[i]=false;
            }
        }
    }
    return false;
}


int main(){
    while(scanf("%lld%s",&target,str)!=EOF&&target!=0&&strcmp("END",str)!=0){
        memset(isvisited,false,sizeof(isvisited));
        memset(l,0,sizeof(l));
        //先对数组进行排序后得到的就是最大的
        sort(str,str+strlen(str),cmp);
        for(int i=0;i<strlen(str);i++)
            str[i]=str[i]-'A'+1;
        if(dfs(0))
                for(int i=0;i<5;i++)
                    printf("%c",l[i]+'A'-1);
        else
            printf("no solution");
        printf("\n");
    }
 return 0;
}

比起那些循环多多的就好看多了

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值