ubuntu 大量dpkg依赖错误

转载 2018年04月17日 11:16:36

1.info文件夹更名

sudo mv /var/lib/dpkg/info /var/lib/dpkg/info_old 


2.新建一个新的info文件夹

sudo mkdir /var/lib/dpkg/info


3.确保软件包列表是否为最新的

sudo apt-get update


4.修复依赖关系,安装程序包所依赖的包

apt-get -f install


5.执行完上一步操作后会在新的info文件夹下生成一些文件,现将这些文件全部移到info_old文件夹下:

sudo mv /var/lib/dpkg/info/* /var/lib/dpkg/info_old


6.把自己新建的info文件夹删掉

sudo rm -rf /var/lib/dpkg/info


7.把以前的info文件夹重新改回名字

 sudo mv /var/lib/dpkg/info_old /var/lib/dpkg/info



转自:https://segmentfault.com/q/1010000000117928

ubuntu dpkg -i 依赖问题

在使用 dpkg -i 安装deb包后,会出现依赖关系而不能正常安装软件,这个时候先更新下源然后解决依赖关系后重装即可。sudo apt-get update # 更新 sudo apt-get -f...
  • ROVAST
  • ROVAST
  • 2016-07-03 22:05:46
  • 7773

ubuntu dpkg 依赖关系 解决

在安装deb的过程中有的时候会遇到安装失败。 提示:包的依赖关系无法自动解决。 解决办法: sudo apt-get -f install -f 修复dpkg依赖关系 然后在重新尝试安...
  • nitianxiaozi
  • nitianxiaozi
  • 2017-07-25 22:40:16
  • 965

Ubuntu下,dpkg安装出错的修复

参考 http://www.khattam.info/2009/08/04/solved-subprocess-pre-removal-script-returned-error-exit-stat...
  • harvey2008
  • harvey2008
  • 2014-05-28 14:33:14
  • 1262

dpkg安装deb缺少依赖包的解决方法--Ubuntu 16.04 LTS 安装网易云音乐

dpkg安装deb缺少依赖包的解决方法--Ubuntu 16.04 LTS 安装网易云音乐 一、去网易云音乐官网下载对应的安装包. 我下载的是netease-cloud-music_1.0.0...
  • seek_of
  • seek_of
  • 2017-09-10 10:36:08
  • 1002

Ubuntu软件安装卸载涉及包依赖的问题

Ubuntu下安装或卸载软件遇到的包依赖的问题
  • Programmer_xxx
  • Programmer_xxx
  • 2016-07-09 09:51:57
  • 6573

Ubuntu解决软件相互依赖问题

这么棘手的一个问题,在折腾了N久之后竟然被我解决了.然而没有截图,现在仅把大致步骤说一下: 一. apt-get update提示404问题 出现此问题说明机器上存在某些软件,在当前指定的源服务器...
  • FoxBryant
  • FoxBryant
  • 2017-02-17 09:42:53
  • 1262

dpkg:处理google-chrome-stable(--install)时候出错

转载自 http://blog.csdn.net/eland_edwiin/article/details/8177997 ubuntu下安装chrome出现了错误:dpkg:处理 google-c...
  • zjm750617105
  • zjm750617105
  • 2015-09-16 21:14:10
  • 3360

ubutunt中apt-get和dpkg结合使用完全清除软件包及依赖信息方法

通常,ubuntu中卸载软件包时,我们习惯使用: sudo apt-get remove |
  • wtxwd
  • wtxwd
  • 2014-08-07 16:28:58
  • 3988

dpkg 安装 deb 包依赖

通过 dpkg 命令安装 .deb 包时,经常会出现未安装依赖的情况,比如下图安装有道词典时的情景: 可以通过 apt 命令安装所需依赖,使用 -f 选项修复依赖sudo apt -f -y ins...
  • bedisdover
  • bedisdover
  • 2017-04-08 11:15:56
  • 1792

ubuntu 16.04 dpgk安装deb包因缺少依赖文件失败

【先贴出解决方案(基于Ubuntu)】: 使用dpkg -i   *.deb 的时候出现依赖没有安装 使用apt-get -f -y install  解决依赖问题后再执行dpkg安装deb包 ...
  • a2020883119
  • a2020883119
  • 2017-07-08 17:42:34
  • 2940
收藏助手
不良信息举报
您举报文章:ubuntu 大量dpkg依赖错误
举报原因:
原因补充:

(最多只允许输入30个字)