Doing Homework again

描述

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

输入

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

输出

For each test case, you should output the smallest total reduced score, one line per test case.
 

样例输入

       
       
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

样例输出

       
       
0 3 5
 

#include<stdio.h>
int js1[1100],js2[1100];
#include<string.h>
#include<algorithm>
using namespace std;
struct work
{
    int a,b;
} s[1001];
bool cmp(work x,work y)
{
    if(x.a==y.a) return x.b>y.b;
    return x.a>y.a;
}
int main()
{
    int i,j,n,m,t,sum,e,k,max;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0; i<n; i++)
        {
            scanf("%d",&s[i].a);

        }
        for(i=0; i<n; i++)
        {
            scanf("%d",&s[i].b);
        }
        sort(s,s+n,cmp);
        memset(js1,0,sizeof(js1));
        sum=0;
        int nn=n;
        while(n--)
        {
            int flag=0;
            j=0;
            memset(js2,0,sizeof(js2));
            for(i=0; i<nn; i++)
            {
                if(s[i].a>=n+1)
                {
                    js1[j]=i;
                    js2[j]=s[i].b;
                    j++;
                    flag=1;
                }
                else
                {
                    js2[j]=-1;
                    j++;
                }
            }
            if(flag==0)
                continue;
            e=js1[0];
            max=js2[e];
            for(int f=0; f<j; f++)
            {
                if(max<js2[f])
                {
                    max=js2[f];
                    e=f;
                }
            }
            //printf("%d ",max);
            s[e].b=0;

        }
        for(i=0; i<nn; i++)
            sum=sum+s[i].b;
        printf("%d\n",sum);
    }


    return 0;
}
贪心思路:从后往前更方便一些,例如,第六天交哪份作业,第四天交哪份作业,第三天交哪份作业。。。最后剩下的分数相加就是减的最少分数。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值