ZOJ 2655 Water Pipe bfs 带方向状态

链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2655

Water Pipe

Time Limit: 5 Seconds      Memory Limit: 32768 KB

Two waterworks want to connect to each other with water pipes. Just as the map shows, the waterworks sit on two corners of the city. The city is a rectangle, and is divided into a lot of small squares. Water pipes are placed in these squares. Only one pipe can be placed in each square. There are two types of pipe: straight pipe and bend pipe. You can rotate them if necessary. Two types of pipe have different prices. You are assigned to calculate the minimum cost to connect the two waterworks.

Input:

There are several test cases. Each test case contains two parts.

The first part is a line of for integers: the width of the city, the length of the city, the price of the straight pipe, the price of the bend pipe(1<=width,length<=100, 0<=price<=100).

The second part is a map of the city, "b" stands for block on that square, while "*" stands for a blank square which you can place water pipe in.

Output:

For each test case, print in one line the minimum cost to connect the waterworks. If can not to connect to each other, output "impossible".

Sample Input:

 
1 2 3 4
*
*
5 5 8 0
b****
*****
**bb*
**bb*
*****
5 5 8 10
b****
*****
**bb*
**bb*
*****
1 1 38 89
*
1 1 3 3
b

Sample Output:

8
8
76
38
impossible

题意:

从右上角出发到左下角。搭一个直水管花费str,弯的ben。

问最小搭水管的花费。


做法

直接可以从地图右上角也就是( 1,n)点 出发,初始方向是向左的。注意此时还没有搭任何的水管。方向是因为从左边那个水厂流入所以向左。

然后就是在这个格子建水管,如果建直水管,他就继续向左,然后花费直水管的钱,到达(1,n-1)点,然后当前方向还是向左,然后在vis数组记录最小步数。


注意走的时候,只能走三个方向,要么转弯,要么直走,不能往回走,和题目矛盾,也没什么意义。 


然后到达终点旁边的 那个格子的时候,此时,这个格子还没建造水管,如果此时向下,你可以花费转弯水管的钱让他到达终点,

如果此时向左,那么只用花费 直水管的钱让他到达终点。

如果其他两个方向,是无法更新答案的。


.

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <malloc.h>
#include <ctype.h>
#include <math.h>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
#include <stack>
#include <queue>
#include <vector>
#include <deque>
#include <set>
#include <map>
 
#define inf 0x7f7f7f7f
int dir[4][2]={1,0,0,1,-1,0,0,-1};

struct point
{
	int x,y;
	int ff;//在当前位置 朝向哪里
	int cost;
	bool operator <(const point& b)const
	{
		return cost>b.cost;
	}
};

int vis[110][110][4];
char mp[110][110];
int n,m;
int vst(point a)
{ 
	if(a.x<1||a.x>n||a.y<1||a.y>m)
		return 0;
	if(mp[a.x][a.y]=='b')
		return 0;
	if(vis[a.x][a.y][a.ff]>a.cost)
	{
		vis[a.x][a.y][a.ff]=a.cost;
		return 1;
	}
	return 0;
}
 
int str,ben;// zhijia  wanjia
int ans;

// 最优路径 不会有重叠出现

void bfs()
{
	priority_queue<point>q;
	memset(vis,inf,sizeof vis);
	point sta,nxt,nw;
	sta.x=1;
	sta.y=m;
	sta.ff=3;
	sta.cost=0;
	if(vst(sta))
	q.push(sta); 
	ans=inf;
	while(!q.empty())
	{
		nw=q.top();
		//printf("%d\n",nw.cost);
		if(nw.x==n&&nw.y==1)
		{
			if(nw.ff==3)
				ans=min(ans,nw.cost+str);
			else if(nw.ff==0)
				ans=min(ans,nw.cost+ben);
		}
		q.pop();
		for(int i=-1;i<=1;i++)
		{
			int tur=(nw.ff+i+4)%4;
			nxt=nw;
			nxt.ff=tur;
			nxt.x+=dir[tur][0];
			nxt.y+=dir[tur][1];
			if(i==0)
				nxt.cost+=str;
			else
				nxt.cost+=ben;
			if(vst(nxt))
			{
				q.push(nxt);
			}
		}
	} 

}
int main()
{
	while(scanf("%d%d%d%d",&m,&n,&str,&ben)!=EOF)
	{
		for(int i=1;i<=n;i++)
			scanf("%s",mp[i]+1);
		bfs();
		if(ans!=inf)
		printf("%d\n",ans);
		else
			printf("impossible\n");
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值