HDU 4722-Good Numbers

Description

If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.
 

Input

The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).
 

Output

For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
 

Sample Input

    
    
2 1 10 1 20
 

Sample Output

    
    
Case #1: 0 Case #2: 1

Hint

The answer maybe very large, we recommend you to use long long instead of int. 

打表找规律~

发现每100位便可以找到10各个位置加起来是10的倍数的数字...只要判断a 和b 是100的几倍即可~~

CODE:

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<string>
using namespace std;

int main()
{
    int T;
    scanf("%d",&T);
    for(int tt=1;tt<=T;tt++)
    {
        long long a,b;
        scanf("%I64d%I64d",&a,&b);
        long long ans=(b/100-a/100)*10;
        long long aa=a/100*100;
        while(aa<a)
        {//printf("1\n");
            long long ta=aa;
            long long t=0;
            while(ta!=0)
            {
                t+=ta%10;
                ta=ta/10;
            }
            if(t%10==0)
            {
                ans--;
            }
            aa++;
        }
        long long bb=b/100*100;
        while(bb<=b)
        {//printf("1\n");
            long long tb=bb;
            long long t=0;
            while(tb!=0)
            {
                t+=tb%10;
                tb=tb/10;
            }
            if(t%10==0)
            {
                ans++;
            }
            bb++;
        }
        printf("Case #%d: %I64d\n",tt,ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值