杭电1102————最小生成树prim

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13994    Accepted Submission(s): 5323


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
 

Sample Input
  
  
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
  
  
179
题意比较明确就不说了....
开始的时候我想的太过复杂,用了并查集+prim,大体思路如下:
<span style="font-family:Microsoft YaHei;font-size:14px;">if(读入的图是全部连通的)
	prim()
	print sum
else
	sum -= 每一个连通子图的最小生成树
	
answer = sum </span>

于是用并查集判断是否连通,求出每一个连通分量的最小生成树,减去即得答案。
但是求连通分量的最小生成树我觉得太麻烦了,至少我不会实现....
但是经人点拨才发现自己智商确实拙计,只需要把已经有联系的边的权重置为0,然后就是简单的prim.......(智商实在太拙计了,不会思维)
#include <stdio.h>
#include <string.h>
#define maxn 105
#define INF 100000

int G[maxn][maxn];
int intree[maxn];
int minlen[maxn];
int sum;
void initialize_MST()
{
	memset(intree,0,sizeof(intree));
	for(int i = 0 ; i <= maxn -1 ; i++)
		for(int j = 0 ; j <= maxn - 1 ; j++)
			G[i][j] = INF;
	sum = 0; 
}

void prim(int n)
{
	int templen,node;
	
	for(int i = 1 ; i <= n ; i++)
		minlen[i] = G[1][i];
	intree[1] = 1 ;
	for(int i = 2  ; i <= n ; i++)
	{
		templen = INF;
		for(int j= 1 ; j <= n ; j++)
		{
			if(templen > minlen[j] && !intree[j])
			{
				templen = minlen[j];
				node = j;
			}
		}
		sum += templen;
		intree[node] = 1 ;
		for(int j = 1 ; j <= n ; j++)
			if(!intree[j] && minlen[j] > G[node][j])
				minlen[j] = G[node][j];
	}
}
int main()
{
	int n,m;
	int vertex1,vertex2;
	
	while(scanf("%d",&n) != EOF)
	{
		initialize_MST();
		for(int i = 1 ; i <= n ; i++)
			for(int j = 1 ; j <= n ; j++)
				scanf("%d",&G[i][j]);
		scanf("%d",&m);
		for(int i = 1 ; i <= m ; i++)
		{
			scanf("%d%d",&vertex1,&vertex2);
			G[vertex1][vertex2] = G[vertex2][vertex1] = 0;
		}
		prim(n);
		printf("%d\n",sum);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值