杭电1102(最小生成树+prim)

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)

Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

思路:

题意:有n个村庄,村庄间已经有若干条路,要继续为村庄建路,使得所有的村庄都能连通,并且总路程最短。

方法:已经有路的不再考虑距离,prim算法。

AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

#define maxn 110
#define INF 0x3f3f3f3f 
int n,ans;
int city[maxn][maxn];
int dis[maxn];
int vis[maxn];

void prim()
{
    int min,k;
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++)
    {
        dis[i]=city[1][i];
    }
    dis[1]=0;
    vis[1]=1;
    for(int i=1;i<=n;i++)
    {
        min=INF;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&min>dis[j])
            {
                k=j;
                min=dis[j];
            }
        }
        if(min==INF) break;
        vis[k]=1;
        ans+=dis[k];
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&dis[j]>city[k][j])
            {
                dis[j]=city[k][j];
            }
        }
    }
}

int main()
{
    int q,a,b;
    while(cin>>n)//n个村庄 
    {
        for(int i=1;i<=n;i++)//村庄间距离 
        {
            for(int j=1;j<=n;j++)
            {
                cin>>city[i][j];
            }
        }
        cin>>q;//q条路 
        for(int i=1;i<=q;i++)
        {
            cin>>a>>b;//a,b已连通,不再考虑距离 
            city[a][b]=city[b][a]=0;
        }
        ans=0;
        prim();
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值