HDOJ 1004 字符串处理(字符串统计)

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 97201    Accepted Submission(s): 37153


Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you. 
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
  
  
5 green red blue red red 3 pink orange pink 0
 

Sample Output
  
  
red pink
一 分析
这道题要解决的问题很明确,也很简单,就是要统计每个字符串出现的次数,然后找出现最多的那一个。
二 算法
每次加入新的元素与之前出现的每一个进行一次比较,如果这个color之前出现过,这个color的数量就+1,如果我们仔细思考可以发现这个方法和我们人工统计的方法其实没有什么区别。
三 数据结构
确定了算法以后,我们就要根据我们设计的算法构造数据结构,根据上面算法的要求,我们需要一个能存放字符串的数组,和一个能存放次数的数组,并且这两个数组能通过其数组下标一一准确对应起来。

//

//  main.cpp

//  1004

//

//  Created by 张嘉韬 on 16/1/9.

//  Copyright © 2016 张嘉韬. All rights reserved.

//

#include <iostream>

#include <cstring>

using namespace std;

int main(int argc, const char * argv[]) {

    //freopen("/Users/zhangjiatao/Desktop/input.txt","r",stdin);

    int n;

    while(cin>>n)

    {

        if(n==0) break;

        char color[1001][16];

        int counter[1001];

        memset(counter,0,sizeof(counter));

        for(int i=1;i<=n;i++)

        {

            cin>>color[i];

            counter[i]=1;

        }

        for(int i=1;i<=n-1;i++)

        {

            for(int j=i+1;j<=n;j++)

            {

                if(strcmp(color[i],color[j])==0)

                    counter[i]++;

            }

        }

        int max,maxnum;

        max=0,maxnum=0;

        for(int i=1;i<=n;i++)

        {

            if(counter[i]>max)

            {

                max=counter[i];

                maxnum=i;

            }

        }

        cout<<color[maxnum]<<endl;

    }

    return 0;

}

四 总结
1.上边的代码用了跟简单的一种方法,先把所有的字符串储存起来,再跟其之前的所有字符串相比较,最后再统计最大的次数。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值