2014北京网络赛1007||hdu5038 模拟

http://acm.hdu.edu.cn/showproblem.php?pid=5038

Problem Description
Ted is a employee of Always Cook Mushroom (ACM). His boss Matt gives him a pack of mushrooms and ask him to grade each mushroom according to its weight. Suppose the weight of a mushroom is w, then it’s grade s is 

s = 10000 - (100 - w)^2

What’s more, Ted also has to report the mode of the grade of these mushrooms. The mode is the value that appears most often. Mode may not be unique. If not all the value are the same but the frequencies of them are the same, there is no mode.
 

Input
The first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow.

The first line of each test cases contains one integers N (1<=N<=10^6),denoting the number of the mushroom.

The second line contains N integers, denoting the weight of each mushroom. The weight is greater than 0, and less than 200.
 

Output
For each test case, output 2 lines.

The first line contains "Case #x:", where x is the case number (starting from 1) 

The second line contains the mode of the grade of the given mushrooms. If there exists multiple modes, output them in ascending order. If there exists no mode, output “Bad Mushroom”.
 

Sample Input
  
  
3 6 100 100 100 99 98 101 6 100 100 100 99 99 101 6 100 100 98 99 99 97
 

Sample Output
  
  
Case #1: 10000 Case #2: Bad Mushroom Case #3: 9999 10000
这道题有必要说一下题目大意了,比赛时我们理解错题意了==

题目大意:给你n个0~200之间的数,每个数对应有一个函数值,若所有的函数值出现的频率都相等而自变量不相等时是Bad,否则输出频率最高的函数值,若有多个升序输出。

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;

int sum,num,cot[10006];
int T,n;

int main()
{
    int tt=0;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        int num=0,sum=0;
        int maxx=0,minn=10005;
        memset(cot,0,sizeof(cot));
        for(int i=0;i<n;i++)
        {
            int w;
            scanf("%d",&w);
            int s=10000-(100-w)*(100-w);
            if(s>maxx) maxx=s;
            if(s<minn) minn=s;
            if(!cot[s])
                num++;
            cot[s]++;
            if(cot[s]>sum) sum=cot[s];
        }
        //printf("%d**%d\n",sum,num);
        printf("Case #%d:\n",++tt);
        if(sum*num==n&&num>1)
            printf("Bad Mushroom\n");
        else
        {
            int p=0;
            for(int i=minn;i<=maxx;i++)
            {
                if(cot[i]==sum)
                {
                    if(p)printf(" ");
                    printf("%d",i);
                    p=1;
                }
            }
            printf("\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值