http://acm.hdu.edu.cn/showproblem.php?pid=5038
Problem Description
Ted is a employee of Always Cook Mushroom (ACM). His boss Matt gives him a pack of mushrooms and ask him to grade each mushroom according to its weight. Suppose the weight of a mushroom is w, then it’s grade s is
s = 10000 - (100 - w)^2
What’s more, Ted also has to report the mode of the grade of these mushrooms. The mode is the value that appears most often. Mode may not be unique. If not all the value are the same but the frequencies of them are the same, there is no mode.
What’s more, Ted also has to report the mode of the grade of these mushrooms. The mode is the value that appears most often. Mode may not be unique. If not all the value are the same but the frequencies of them are the same, there is no mode.
Input
The first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow.
The first line of each test cases contains one integers N (1<=N<=10^6),denoting the number of the mushroom.
The second line contains N integers, denoting the weight of each mushroom. The weight is greater than 0, and less than 200.
The first line of each test cases contains one integers N (1<=N<=10^6),denoting the number of the mushroom.
The second line contains N integers, denoting the weight of each mushroom. The weight is greater than 0, and less than 200.
Output
For each test case, output 2 lines.
The first line contains "Case #x:", where x is the case number (starting from 1)
The second line contains the mode of the grade of the given mushrooms. If there exists multiple modes, output them in ascending order. If there exists no mode, output “Bad Mushroom”.
The first line contains "Case #x:", where x is the case number (starting from 1)
The second line contains the mode of the grade of the given mushrooms. If there exists multiple modes, output them in ascending order. If there exists no mode, output “Bad Mushroom”.
Sample Input
3 6 100 100 100 99 98 101 6 100 100 100 99 99 101 6 100 100 98 99 99 97
Sample Output
Case #1: 10000 Case #2: Bad Mushroom Case #3: 9999 10000
题目大意:给你n个0~200之间的数,每个数对应有一个函数值,若所有的函数值出现的频率都相等而自变量不相等时是Bad,否则输出频率最高的函数值,若有多个升序输出。
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
int sum,num,cot[10006];
int T,n;
int main()
{
int tt=0;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
int num=0,sum=0;
int maxx=0,minn=10005;
memset(cot,0,sizeof(cot));
for(int i=0;i<n;i++)
{
int w;
scanf("%d",&w);
int s=10000-(100-w)*(100-w);
if(s>maxx) maxx=s;
if(s<minn) minn=s;
if(!cot[s])
num++;
cot[s]++;
if(cot[s]>sum) sum=cot[s];
}
//printf("%d**%d\n",sum,num);
printf("Case #%d:\n",++tt);
if(sum*num==n&&num>1)
printf("Bad Mushroom\n");
else
{
int p=0;
for(int i=minn;i<=maxx;i++)
{
if(cot[i]==sum)
{
if(p)printf(" ");
printf("%d",i);
p=1;
}
}
printf("\n");
}
}
return 0;
}