hdu2612 两遍BFS

Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest. 
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
 

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200). 
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
 

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
 

Sample Input
  
  
4 4 Y.#@ .... .#.. @..M 4 4 Y.#@ .... .#.. @#.M 5 5 Y..@. .#... .#... @..M. #...#
 

Sample Output
  
  
66 88 66
 



分别从Y和M进行两遍BFS

#include <cstdio>
#include <cstring>
#include<map>
#include <queue>
#include <iostream>
#include <algorithm>
#include <set>
#include <map>
#include <vector>
#define eps 1e-10
#define ll long long
#include<cmath>
using namespace std;
int mm[300][300];
int vis[300][300];
int n,m;
int l[300][300],r[300][300];
int ans[300][300] ;
struct node
{
    int x,y,ans;
};
queue<node> q;
void init( )
{
    for(int i=0; i<n; i++)
        for(int j=0; j<m; j++)
            vis[i][j] = mm[i][j] ;
}
int in(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<m)
        return 1;
    return 0;
}
int dir[4][2]= {{1,0},{-1,0},{0,1},{0,-1}};

void  bfs(node x,int lei)
{
    node next;
    while(!q.empty())   q.pop();
    q.push(x);
    while(!q.empty())
    {
        node tmp = q.front();
        q.pop();
        for(int i=0; i<4; i++)
        {
            int xx = tmp.x + dir[i][0];
            int yy = tmp.y + dir[i][1];
            if(in(xx,yy)&&vis[xx][yy]==-1)
            {

                vis[xx][yy] = 1;
                next.x = xx;
                next.y = yy;
                next. ans = tmp.ans + 1;
                if(lei==1)
                    l[xx][yy] = next.ans;
                else
                    r[xx][yy] = next.ans;
                q.push(next);
            }
            else if(in(xx,yy)&&!vis[xx][yy])
            {
                vis[xx][yy] = 1;
                next.x = xx;
                next.y = yy;
                next.ans = tmp.ans + 1;
                q.push(next);
            }
        }
    }
}
int main()
{
    while(cin>>n>>m)
    {
        int yx,yy,mx,my;
        int cnt = 0;
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m; j++)
            {
                l[i][j] = r[i][j] = 99999999;
                char tmp;
                cin>>tmp;
                if(tmp=='#')
                    mm[i][j] = 1;
                else if(tmp=='.')
                    mm[i][j] = 0;
                else if(tmp=='Y')
                {
                    yx = i,yy = j;
                    mm[i][j] = 0;
                }
                else if(tmp=='M')
                {
                    mm[i][j] = 0;
                    mx = i,my = j;
                }
                else
                    mm[i][j] = -1;
            }
        }
        node a;
        init();
        a.x = yx , a.y =yy ,a.ans = 0;
        bfs(a,1);
        init();
        a.x = mx , a.y =my ,a.ans = 0;
        bfs(a,2);
        int Min = 99999999;
        for(int i=0; i<n; i++)
            for(int j=0; j<m; j++)
                Min = min(Min,l[i][j]+r[i][j]);
        cout<<11*Min<<endl;
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值