HDU 1241 Oil Deposits

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1241

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12731    Accepted Submission(s): 7405


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

Sample Input
  
  
1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
 

Sample Output
  
  
0 1 2 2
 

Source
老规矩,先翻译。虽然我英语很渣,但是看懂题目还是没问题的。

话说有一个石油公司去一个矩阵油场采油,当然这个矩形油场有些地方有油有地方却没有。有油的地方我们称它为藏油处,如果它的上下左右或者相邻的斜对角也有藏油处,他们就会汇在一起,我们又称它为石油存储地。现在给你一张图,叫你求出共有几个石油存储地。

其中‘@’表示该点是藏油处,‘*’表示该点没有油。

接下来开始搜索,每找到一个藏油点,如果它没被搜过,就以它为起点深搜,并且答案加1,直到整幅图全部搜完。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<sstream>
#include<vector>
#include<map>
#include<list>
#include<set>
#include<queue>
#define LL long long
using namespace std;
const int maxn=1005,maxe=100005,inf=1<<29;
int dir[][2]=
{
    {0,1},{-1,1},{-1,0},{-1,-1},{0,-1},{1,-1},{1,0},{1,1}
};
bool vis[maxn][maxn];
char Map[maxn][maxn];
int n,m;
void dfs(int x,int y)
{
    vis[x][y]=1;
    for(int i=0;i<8;i++)
    {
        int nx=dir[i][0]+x,ny=dir[i][1]+y;
        if(0<=nx&&nx<n&&0<=ny&&ny<m&&!vis[nx][ny]&&Map[nx][ny]=='@')
        {
            dfs(nx,ny);
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m)&&(n+m))
    {
        memset(vis,0,sizeof(vis));
        int ans=0;
        for(int i=0;i<n;i++) scanf("%s",Map[i]);
        for(int i=0;i<n;i++)
            for(int j=0;j<m;j++)
            if(Map[i][j]=='@'&&!vis[i][j]) ans++,dfs(i,j);
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值