HDU 1002 A + B Problem II

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 227417    Accepted Submission(s): 43641


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

模拟手工加法喽,用字符串读取数据,然后倒过来计算。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<sstream>
#include<vector>
#include<map>
#include<stack>
#include<list>
#include<set>
#include<queue>
#define LL long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1 | 1
using namespace std;
const int maxn=1005,maxe=100005,inf=1<<29;
int n,m;
char a[maxn],b[maxn];
int na[maxn],nb[maxn];
void add()
{
    int la=strlen(a),lb=strlen(b),lmax=max(la,lb);
    memset(na,0,sizeof(na));
    memset(nb,0,sizeof(nb));
    for(int i=0;a[i];i++) na[la-i-1]=a[i]-'0';
    for(int i=0;b[i];i++) nb[lb-i-1]=b[i]-'0';
    for(int i=0;i<lmax;i++) na[i]+=nb[i],na[i+1]+=na[i]/10,na[i]%=10;
    printf("%s + %s = ",a,b);
    if(!na[lmax]) lmax--;
    while(lmax>=0) printf("%d",na[lmax--]);
    printf("\n");
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int T=1;T<=t;T++)
    {
        printf("Case %d:\n",T);
        scanf("%s%s",a,b);
        add();
        if(T!=t) printf("\n");
    }
    return 0;
}

JAVA版AC代码

<pre name="code" class="java">import java.util.*;
import java.math.*;
import java.io.*;
public class Main {
	static Scanner cin=new Scanner(System.in);
	static public void main(String args[]){
		BigInteger a,b;
		int t;
		t=cin.nextInt();
		for(int Case=1;Case<=t;Case++)
		{
			a=cin.nextBigInteger();
			b=cin.nextBigInteger();
			System.out.println("Case "+Case+":");
			System.out.println(a+" + "+b+" = "+a.add(b));
			if(Case<t) System.out.println("");
		}
		
	}

}

 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值