HDU 1250 Hat's Fibonacci

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1250

Hat's Fibonacci

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7969    Accepted Submission(s): 2598


Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
  
  
100
 

Sample Output
  
  
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
高精度加法。

水题。

不解释。

直接上代码。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<sstream>
#include<vector>
#include<map>
#include<stack>
#include<list>
#include<set>
#include<queue>
#define LL long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1 | 1
using namespace std;
const int maxn=10005,maxe=100005,inf=1<<29;
int n,m;
char a[maxn],b[maxn],c[maxn],d[maxn],e[maxn];
int na[maxn],nb[maxn],nc[maxn],nd[maxn];
void add()
{
    int la=strlen(a),lb=strlen(b),lab=max(la,lb),lc=strlen(c),ld=strlen(d);
    int lcd=max(lc,ld),lmax=(lab,lcd);
    memset(na,0,sizeof(na));
    memset(nb,0,sizeof(nb));
    memset(nc,0,sizeof(nc));
    memset(nd,0,sizeof(nd));
    for(int i=0;a[i];i++) na[la-i-1]=a[i]-'0';
    for(int i=0;b[i];i++) nb[lb-i-1]=b[i]-'0';
    for(int i=0;c[i];i++) nc[lc-i-1]=c[i]-'0';
    for(int i=0;d[i];i++) nd[ld-i-1]=d[i]-'0';
    for(int i=0;i<lmax;i++) na[i]+=nb[i]+nc[i]+nd[i],na[i+1]+=na[i]/10,na[i]%=10;
    if(na[lmax]) lmax++;
    for(int i=0;i<lmax;i++) e[lmax-i-1]=na[i]+'0';
    e[lmax]='\0';
}
int main()
{
    while(~scanf("%d",&n))
    {
        strcpy(a,"1");strcpy(b,"1");
         strcpy(c,"1");strcpy(d,"1");
         if(n<=4) {printf("1\n");continue;}
        for(int i=5;i<=n;i++)
        {
            add();
            strcpy(a,b);strcpy(b,c);
            strcpy(c,d);strcpy(d,e);
        }
        printf("%s\n",e);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值