poj 3461 Oulipo

Oulipo
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 22965 Accepted: 9179

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A','B','C', …,'Z'} and two finite strings over that alphabet, a wordW and a textT, count the number of occurrences ofW inT. All the consecutive characters of W must exactly match consecutive characters ofT. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {'A', 'B','C', …,'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the stringW).
  • One line with the text T, a string over {'A', 'B','C', …,'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the wordW in the textT.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0
//题目大意:给一个母串和子串,母串中包含子串的个数,输出个数
//关键点:next 数组的理解和应用
//心得:搞了一上午kmp算 模模糊糊的理解了next,又自己写了两次,下午来了写出来。
// 十天是福是祸不知道,差距拉大,仍需努力。
//time:2014_7_28  14:36
#include<stdio.h>
#include<string.h>
const int MAX=1000000+10;
const int MY_MAX= 10000+10;
char pattern[MAX];
char str[MY_MAX];
int next[MY_MAX];
int ans=0;
void GetNext()
{
     int i=0;
     int j=-1;
     next[0]=-1;
     while (str[i])
     {
         if (j==-1||str[i]==str[j])
         {
            i++;
            j++;
            if (str[i]!=str[j])
            {
               next[i]=j;
            }
            else
            {
                next[i]=next[j];
            }
            /*
            for (int t=0;str[t];t++)
            {
                printf("%d ",next[t]);
            }
            printf("\n");
            */
         }
         else
             j=next[j];//相当于自身调用自身的next数组  
     }     
}

void kmp()
{
     int i=0;
     int j=0;
     ans=0;
     GetNext();
     int str_len=strlen(str);
     while (pattern[i])
     {
         if (j==-1||str[j]==pattern[i])
         {
            i++;
            j++;
            if(j==str_len)
            {
            ans++;
            j=next[j];
            }  
         }
         else
         {
             j=next[j];
         }             
     }
}

int main()
{
    int T;
    scanf("%d",&T);
    while (T--)
    {
          
          ans=0;
         scanf("%s%s",str,pattern);
         kmp();
         printf("%d\n",ans); 
    }
return 0;
} 



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值