Cow Exhibition
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 9407 | Accepted: 3611 |
Description
"Fat and docile, big and dumb, they look so stupid, they aren't much
fun..."
- Cows with Guns by Dana Lyons
The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.
Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.
fun..."
- Cows with Guns by Dana Lyons
The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.
Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.
Input
* Line 1: A single integer N, the number of cows
* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.
* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.
Output
* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.
Sample Input
5 -5 7 8 -6 6 -3 2 1 -8 -5
Sample Output
8
Hint
OUTPUT DETAILS:
Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.
Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.
Source
USACO 2003 Fall
/*
搜了半天还是抄的正刚的,,,嘘。。。顺便又学会了个fill函数
Time:2014-11-20 21:13
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int INF=1<<28;
const int shift=1000*100;
const int MAXM=1000*200;
const int MAX=105;
int s[MAX],f[MAX];
int dp[MAXM+10];
int main(){
int n;
scanf("%d",&n);
for(int i=0;i<n;i++){
scanf("%d%d",&s[i],&f[i]);
}
fill(dp,dp+MAXM,-INF);//跟正刚又学会了个函数
dp[shift+0]=0;
int l=0,r=0;
int start=l;int end=r;
for(int i=0;i<n;i++){
l=min(l,l+s[i]); r=max(r,r+s[i]);
start=l;end=r;int step=1;//放里边,多次循环使用
if(s[i]>0){
step=-1; swap(start,end);
}
for(int j=start;j!=end+step;j+=step){//s[i]小于0的话就变成反向循环了
dp[j+shift]=max(dp[j-s[i]+shift]+f[i],dp[j+shift]);
}
}
int ans=0;
for(int i=0;i<=r;i++){//s[i]和f[i]之和最大
if(dp[i+shift]>=0)
ans=max(ans,i+dp[i+shift]);
}
printf("%d\n",ans);
return 0;
}