杭电3371 Connect the Cities(最小生成树 prim)

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10042    Accepted Submission(s): 2869


Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

Sample Input
  
  
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

Sample Output
  
  
1
/*
Kruscal 贡献了2个TLE 没输出-1贡献了一次WA
Time:2014-08-12 20:53
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int INF=1<<28;
const int MAX=550;
int map[MAX][MAX];
int d[MAX];
bool vis[MAX];
int N,M,K;
void Init(){
	for(int i=1;i<=N;i++){
		for(int j=1;j<=N;j++){
			if(i==j)
			map[i][j]=0;
			else
			map[i][j]=map[j][i]=INF;
		}
		d[i]=0;vis[i]=0;
	}
}
int Prim(){
	
	for(int i=1;i<=N;i++){
		d[i]=map[1][i];
	}
	vis[1]=1;
	int Mst=0;
	int u=0;
	for(int i=1;i<N;i++){
		int minV=INF;
		for(int j=1;j<=N;j++){
			if(!vis[j]&&d[j]<=minV){
				minV=d[j];
				u=j;
			}
		}
		vis[u]=1;
		if(d[u]==INF)return -1;
		Mst+=d[u];
		//printf("Mst=%d\n",Mst);
		for(int j=1;j<=N;j++){
			if(!vis[j]&&d[j]>map[u][j]){
				d[j]=map[u][j];
			}
		}
	}
	return Mst;
}
int main(){
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%d%d%d",&N,&M,&K);
			int a,b,c;
			Init();
		for(int i=1;i<=M;i++){
			scanf("%d%d%d",&a,&b,&c);
			if(map[a][b]>c)
			map[a][b]=map[b][a]=c;
		}
			int t;
			int r[MAX];
			/*
		for(int i=1;i<=N;i++){
		for(int j=1;j<=N;j++)
			printf("%d ",map[i][j]);
		printf("\n");
		}
		*/
		for(int i=0;i<K;i++){
			scanf("%d",&t);
			for(int i=1;i<=t;i++)
			scanf("%d",&r[i]);
			
			for(int i=1;i<=t;i++)
			for(int j=1;j<=t;j++){
				if(i!=j)
				map[r[i]][r[j]]=0;
			}
		}
		/*
		for(int i=1;i<=N;i++){
		for(int j=1;j<=N;j++)
			printf("%d ",map[i][j]);
		printf("\n");
		}
		*/
		int Mst=Prim();
		printf("%d\n",Mst);	
	}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值