杭电1142 A Walk Through the Forest (最短路+DFS+dp)

A Walk Through the Forest

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 1   Accepted Submission(s) : 1
Problem Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable. The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.
 

Input
Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.
 

Output
For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647
 

Sample Input
  
  
5 6 1 3 2 1 4 2 3 4 3 1 5 12 4 2 34 5 2 24 7 8 1 3 1 1 4 1 3 7 1 7 4 1 7 5 1 6 7 1 5 2 1 6 2 1 0
 

Sample Output
  
  
2 4
/*
题目大意:求最短路,不过有限制条件,英文题搞不太明白,最短路又不熟,,, 2 为终点,1 为起点,问题是求从 1 到 2 的路径的条数,但是有个要求就是要想走a到b这一条路,必须b到终点的最短路径小于a到终点的最短路,思路是先从终点 2 求单源最短路,之后从起点 1 开始DFS,进行记忆化搜索找路的条数,搜索的条件就是map[a][b]!=INF&&d[a]>d[b].因为得保证a b之间有路可走
最短路刚开始搞,就会个Dijkstra,SPFA都不熟 还是看了人家的好几次才搞出来、。
加油!!!
Time:2014-8-20
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX=1000+10;
const int INF=1<<20;
int N,M;
bool vis[MAX];
int d[MAX],map[MAX][MAX];
int dp[MAX];
void Init(){
	memset(vis,0,sizeof(vis));
	memset(d,0,sizeof(d));
	memset(dp,0,sizeof(dp));
	for(int i=0;i<=N;i++){
		for(int j=i;j<=N;j++){
			if(i!=j){
				map[j][i]=map[i][j]=INF;
			}else{
				map[i][j]=0;
			}
		}
	}
	scanf("%d",&M);
	while(M--){
		int a,b,c;
		scanf("%d%d%d",&a,&b,&c);
		map[b][a]=map[a][b]=c;
	}
}
void Dijkstra(int start){
	for(int i=1;i<=N;i++){
		d[i]=map[start][i];
	}vis[start]=true;
	for(int i=1;i<N;i++){
		int minV=INF;
		int u;
		for(int j=1;j<=N;j++){
			if(!vis[j]&&minV>d[j]){
				minV=d[j];
				u=j;
			}
		}
		vis[u]=true;
		for(int j=1;j<=N;j++){
			if(!vis[j]&&d[j]>d[u]+map[u][j])
			d[j]=d[u]+map[u][j]; 
		}
	}
}
int DFS(int v){
	if(dp[v])return dp[v];
	if(v==2) return 1;
	for(int i=1;i<=N;i++){
		if(map[v][i]<INF&&d[v]>d[i])
		dp[v]+=DFS(i);
	}
	return dp[v];
}
void solve(){
	while(scanf("%d",&N),N){
		Init();
		Dijkstra(2);
		printf("%d\n",DFS(1));
	}
}
int main(){
	solve();
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值