poj3050 Hopscotch(dfs基础)

Hopscotch
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2119 Accepted: 1517

Description

The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes. 

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited). 

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201). 

Determine the count of the number of distinct integers that can be created in this manner.

Input

* Lines 1..5: The grid, five integers per line

Output

* Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

Hint

OUTPUT DETAILS: 
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

Source

USACO 2005 November Bronze
/*
深搜题做太少了,总是犯同一个低级错误,错误代码贴下边,,以后看的时候多注意。。。
Tme:2014-11-16 12:06
*/
#include<cstdio>
#include<cstring>
#include<map>
using namespace std;
int m[10][10];
int move[4][2]={0,1,0,-1,1,0,-1,0};
int ans;
map<int,int>mp;
void DFS(int x,int y,int n,int val){
	if(n==6){
		if(mp[val]++==0){
			ans++;
			//printf("map=%d\n",val); 
		}
		return;
	}
	int mx,my;
	for(int i=0;i<4;i++){
		mx=x+move[i][0];
		my=y+move[i][1];
		if(mx>=0&&mx<5&&my>=0&&my<5){
			//val=val*10+m[x][y];  不能写到外边,,郁闷。。。 
			DFS(mx,my,n+1,val*10+m[mx][my]);
		}
	}
}
int main(){
	for(int i=0;i<5;i++){
		for(int j=0;j<5;j++){
			scanf("%d",&m[i][j]);
		}
	}
	ans=0;
	mp.clear();
	for(int i=0;i<5;i++){
		for(int j=0;j<5;j++){
			DFS(i,j,1,m[i][j]);//注:在hdoj的web_DIY里边传入这个参数错误,改成两个0 能过。
		}
	}
	printf("%d\n",ans);
return 0;
} 
/*
#include<cstdio>
#include<cstring>
#include<map>
using namespace std;
int m[10][10];
int move[4][2]={0,1,0,-1,1,0,-1,0};
int ans;
map<int,int>mp;
void DFS(int x,int y,int n,int val){
	if(n==6){
		if(mp[val]++==0){
			ans++;
			printf("map=%d\n",val); 
		}
		return;
	}
	int mx,my;
	for(int i=0;i<4;i++){
		x+=move[i][0];
		y+=move[i][1];
		if(mx>=0&&mx<5&&my>=0&&my<5){
			//val=val*10+m[x][y];  不能写到外边,,郁闷。。。 
			DFS(x,y,n+1,val*10+m[mx][my]);
		}
	}
}
int main(){
	for(int i=0;i<5;i++){
		for(int j=0;j<5;j++){
			scanf("%d",&m[i][j]);
		}
	}
	ans=0;
	mp.clear();
	for(int i=0;i<5;i++){
		for(int j=0;j<5;j++){
			DFS(i,j,1,m[i][j]);
		}
	}
	printf("%d\n",ans);
return 0;
}*/ 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值