POJ 3050 Hopscotch(dfs暴力)

The cows play the child’s game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).

Determine the count of the number of distinct integers that can be created in this manner.

Input

  • Lines 1…5: The grid, five integers per line

Output

  • Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

Hint

OUTPUT DETAILS:
111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.

题意描述:

给出一个5*5的矩阵,每次走六步,组成一个六位数,看看能组成多少个不同的六位数。

解题方法:

在main函数中暴力让每一个点都当作顶点,然后用深搜遍历搜够步然后在判断看这个数是否出现过,如果没有存入数组。最后输出那个数组的下标。

AC代码:

#include<stdio.h>
#include<string.h>

int next[4][2]={1,0, -1,0, 0,1, 0,-1};
int s[100000],e[10][10],ans;
void dfs(int x,int y,int p,int sum)
{
	int tx,ty,k,i,flag;
	if(p==6)
	{
		if(ans==1)
			s[ans++]=sum;
		else
		{
			flag=0;
			for(i=1;i<ans;i++)
			{
				if(s[i]==sum)
				{
					flag=1;
					break;
				}
			}
			if(flag==0)
				s[ans++]=sum;
		}
		return ;
	}
	
	for(k=0;k<4;k++)
	{
		tx=x+next[k][0];
		ty=y+next[k][1];
		if(tx<1||ty<1||tx>5||ty>5)
			continue;
		dfs(tx,ty,p+1,10*sum+e[tx][ty]);
	}
 } 
 
int main(void)
{
	int i,j;
	for(i=1;i<=5;i++)
		for(j=1;j<=5;j++)
			scanf("%d",&e[i][j]);
	ans=1;
	for(i=1;i<=5;i++)
		for(j=1;j<=5;j++)
			dfs(i,j,1,e[i][j]);
	printf("%d\n",ans-1);
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值