POJ 2184 Cow Exhibition 背包问题

题目链接:POJ 2184 Cow Exhibition

题目

Description

“Fat and docile, big and dumb, they look so stupid, they aren’t much
fun…”

  • Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si’s and, likewise, the total funness TF of the group is the sum of the Fi’s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input

  • Line 1: A single integer N, the number of cows

  • Lines 2…N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

Output

  • Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8

解析

两个参数的背包而且限制了每个参数的和的大小,似乎很难靠直接顺推得出结果,但是我们可以把其中一个参数当做容量,得出在保持这个参数的情况下另一个参数的最大值,最后只要遍历一遍这两个参数均为正的组合的和的最值即可。
需要注意的是参数有可能为负,需要先定义一个 b a s e base base,确保数组编号在正数范围内。
还有就是内存不是很够,需要开滚动数组。
代码:

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

const int maxn = 2e5 + 20;
int pre[maxn], now[maxn], s[maxn], f[maxn];
const int base = 1e5 + 10;
int n;

void push(int dex, int * p, int * nw)
{
	if(dex > n){
		int res = 0;
		for(int i = base; i < maxn; i++)
			if(p[i] >= 0)
				res = max(res, p[i] + i - base);
		printf("%d\n", res);
		return;		
	}
	for(int i = 0; i < maxn; i++) nw[i] = p[i];
	for(int j = maxn - 1; j; j--)
		if(p[j] > -(int)1e8)
			nw[j+s[dex]] = max(nw[j+s[dex]], p[j] + f[dex]);	
	push(dex+1, nw, p);
}

int main()
{
	while(scanf("%d", &n) != EOF){
		for(int i = 0; i < maxn; i++) pre[i] = -1e9;
		for(int i = 1; i <= n; i++) scanf("%d%d", &s[i], &f[i]);
		pre[base] = 0;
		push(1, pre, now);
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值