杭电4763 Theme Section(KMP)

Theme Section

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1380    Accepted Submission(s): 697


Problem Description
It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?
 

Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
 

Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.
 

Sample Input
  
  
5 xy abc aaa aaaaba aaxoaaaaa
 

Sample Output
  
  
0 0 1 1 2
 

Source
2013 ACM/ICPC Asia Regional Changchun Online 
/*
ben lai hai xiang da fa gan kai ne ,jie guo shu ru fa chu wen ti le,wu yu .....
shen qi de KMP  
Time:2014-11-22 15:08
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX=1000000+2;
int next[MAX];
char s[MAX];
void Get_next(){
	int i=0,j=-1;
	next[0]=-1;//将首位置初始化为-1 
	while(s[i]){
		if(j==-1||s[i]==s[j]){
			i++;j++;
			next[i]=j; 
/*注意:此题不能用优化后的算法,因为是拓展next求自身前后匹配, 
优化算法加的条件语句 if(s[i]==s[j])next[i]=next[j],因为值越小,跳跃越大 
*/ 
		}else{
			j=next[j];
		}
	}
}
int kmp(){
	Get_next();
	int len=strlen(s);
/*总长度的next值即为自身匹配的最大值*/
	int i,j;
	for(i=next[len];i;i=next[i]){//不存在的话寻找到0跳出 
		for(j=i>>1;j<=len-i;j++){//len应是<= 
			if(next[j]==i)//中间如果能找到next的值为i的,则证明,存在第三个 
				return i;
		}
	}
}
int main(){
	int n;
	scanf("%d",&n);
	while(n--){ 
		memset(s,0,sizeof(s));
		scanf("%s",s);
		printf("%d\n",kmp());
	}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值