poj2752 Seek the Name, Seek the Fame(KMP前后缀相同)

Seek the Name, Seek the Fame
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13160 Accepted: 6509

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm: 

Step1. Connect the father's name and the mother's name, to a new string S. 
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S). 

Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:) 

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above. 

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000. 

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

Source

POJ Monthly--2006.01.22,Zeyuan Zhu
/*
KMP寻找字符串,next数组的值就是前后缀相同的串的长度,因为nxt的值指向前缀的最后一个,刚好就是长度。加油!!!
Time:2015-4-13 8:55
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX=400000+10;
char str[MAX];
int nxt[MAX];
void Get_next(){
    int i,j;memset(nxt,0,sizeof(nxt));
    i=0;j=-1;
    nxt[0]=-1;
    while(str[i]){
        if(j==-1||str[i]==str[j]){
            i++;j++;
            nxt[i]=j;
        }else
            j=nxt[j];
    }
}
int main(){
    while(scanf("%s",str)!=EOF){
        Get_next();
        int len=strlen(str);
        //printf("len=%d\n",len);
        int ans[MAX];
        int k=0;
        for(int i=len;i!=0;i=nxt[i]){
            ans[k++]=nxt[i];
        //求的是前后缀相同的字符串的总长度,相当于nxt数组,因为nxt数组指向的是前缀的末尾,刚好就是长度
        }//最后两个是0
        for(int i=k-2;i>=0;i--){
            printf("%d ",ans[i]);
        }printf("%d\n",len);
    }
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值