ZOJ 2724 Windows Message Queue(二叉堆or优先队列)

Windows Message Queue
Time Limit: 2000 MS      Memory Limit: 65536 KB      64bit IO Format: %lld & %llu
Description

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

Input

There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

Sample Input

  
  
GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

Sample Output

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!



这是一道典型的优先队列问题,队列中储存待处理的消息,按照优先级值递增顺序存放,若优先级相同,则先来者前,后来者后。

一:二叉堆

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

const int maxn=60005;
int top,used;
int heap[maxn];

struct M
{
    char name[100];
    int num;
    int pri;
    int t;
}msg[maxn];

int comp(int a,int b)
{
    if(msg[a].pri<msg[b].pri)
        return -1;
    if(msg[a].pri>msg[b].pri)
        return 1;
    if(msg[a].t<msg[b].t)
        return -1;
    if(msg[a].t>msg[b].t)
        return 1;
    return 0;
}

int main()
{
    char s[100];
    top=0;
    used=0;
    int cn=0;
    while(scanf("%s",s)!=EOF)
    {
        if(strcmp(s,"GET")==0)
        {
            if(!top) printf("EMPTY QUEUE!\n");
            else
            {
                printf("%s %d\n",msg[heap[1]].name,msg[heap[1]].num);
                int k=1;
                heap[k]=heap[top--];
                while(k*2<=top)
                {
                    int t=k*2;
                    if(t<top&&comp(heap[t+1],heap[t])<0)
                        t++;
                    if(comp(heap[t],heap[k])<0)
                    {
                        swap(heap[t],heap[k]);
                        k=t;
                    }
                    else break;
                }
            }
        }
        else
        {
            scanf("%s%d%d",msg[used].name,&msg[used].num,&msg[used].pri);
            msg[used].t=cn++;
            int k=++top;
            heap[k]=used++;
            while(k>1)
            {
                int t=k/2;
                if(comp(heap[t],heap[k])>0)
                {
                    swap(heap[t],heap[k]);
                    k=t;
                }
                else break;
            }
        }
    }
    return 0;
}

二:用优先队列 priority_queue

因为优先队列默认排序是由大到小的,因此自定义优先级。

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <queue>
#include <string.h>
using namespace std;

struct node
{
    friend bool operator<(node a,node b)
    {
        return a.t>b.t;
    }
    char name[50];
    int num;
    int t;
};

int main()
{
    priority_queue<node> Q;
    char c[50];
    node n;
    while(scanf("%s",c)!=EOF)
    {
        if(strcmp(c,"GET")==0)
        {
            if(Q.empty())
                printf("EMPTY QUEUE!\n");
            else
            {
                printf("%s %d\n",Q.top().name,Q.top().num);
                Q.pop();
            }
        }
        else
        {
            scanf("%s %d %d",n.name,&n.num,&n.t);
            Q.push(n);
        }
    }
    return 0;
}
















  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值