hdu 1253 胜利大逃亡

胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24076    Accepted Submission(s): 9218


Problem Description
Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.


 

Input
输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
 

Output
对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
 

Sample Input
  
  
1 3 3 4 20 0 1 1 1 0 0 1 1 0 1 1 1 1 1 1 1 1 0 0 1 0 1 1 1 0 0 0 0 0 1 1 0 0 1 1 0
 

Sample Output
  
  
11
 

Author
Ignatius.L
 
先喷两句,这道题的数据,起点为墙的时候居然是可以的,还有,题目有没有路,出不来的测试数据,这个时候基记得输出-1。。。。。
直接一晚上各种天真的调试,。。。。我发誓这道题我如果不看discuss死都出不来
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int puzzle[60][60][60] , X , Y , Z;
int dir[6][3] ={-1, 0, 0, 1, 0, 0, 0, -1, 0, 0, 1, 0, 0, 0, 1, 0, 0, -1} ;
bool vis[60][60][60];
struct node
{
    int x;
    int y;
    int z;
    int step;
};
int bfs(node s)
{
    queue<node>Q;
    Q.push(s);
    node t, hd;
    while(!Q.empty())
    {
        t = Q.front();
        ///printf("t.x = %d  t.y = %d  t.z = %d\n", t.x, t.y, t.z);
        Q.pop();
        for(int i=0; i<6; ++i)
        {
            ///printf("huang\n");
            hd = t;
            hd.x += dir[i][0];
            hd.y += dir[i][1];
            hd.z += dir[i][2];
            if(hd.x == X - 1 && hd.y == Y - 1 && hd.z == Z - 1)
            {
                ///puts("xue");
                return hd.step + 1;;
            }
            if( !puzzle[hd.x][hd.y][hd.z] && !vis[hd.x][hd.y][hd.z] && hd.x >= 0 && hd.y >= 0 && hd.z >= 0 && hd.x < X && hd.y < Y && hd.z < Z)
            {
                ///printf("%d  %d  %d\n", xx, yy, zz);
                vis[hd.x][hd.y][hd.z] = 1;
                hd.step ++;
                Q.push(hd);
            }
        }
        if(Q.empty()&&(t.x!=X-1||t.y!=Y-1||t.z!=Z-1))///没路出来的时候
        {
            return (-1);
        }
    }
}
int main()
{
    int Time, T, count;
    node start;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d%d%d%d", &X, &Y, &Z, &Time);
        for(int i=0; i<X; ++i)
            for(int j=0; j<Y; ++j)
                for(int k=0; k<Z; ++k)
                    scanf("%d", &puzzle[i][j][k]);
        memset(vis, 0, sizeof(vis));
        if(puzzle[X-1][Y-1][Z-1] || X + Y + Z - 3 > Time)//妈蛋,墙可以作为起点
        {
            printf("-1\n");
            continue;
        }
        start.x = 0;
        start.y = 0;
        start.z = 0;
        start.step = 0;
        vis[start.x][start.y][start.z] = 1;
        count = bfs(start);
        if(count <= Time)
        {
            printf("%d\n", count);
            continue;
        }
        else printf("-1\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值