Can you solve this equation?

Can you solve this equation?
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 19   Accepted Submission(s) : 8
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!
#include<stdio.h>
#include<cmath>
#include<math.h>
int main()
{
	double n,y,low, head, mid;   //  8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y
	scanf("%lf",&n);
	while (n--)
	{	
		scanf("%lf", &y);
		low = 0; head = 100;
		mid = (low + head) / 2.0;
		while (head-low>1e-9)
		{
			if (8 *pow( mid , 4) + 7 *pow( mid , 3) + 2 *pow( mid , 2) + 3 * mid + 6 >y)
				head = mid - 1e-9;
			else
				low = mid + 1e-9;
			mid = (low + head) / 2.0;

		}
		if ((8 * pow(0, 4) + 7 * pow(0, 3) + 2 * pow(0, 2) + 3 * 0 + 6) <= y &&y <= (8 * pow(100, 4) + 7 * pow(100, 3) + 2 * pow(100, 2) + 3 * 100 + 6))
			printf("%0.4lf\n", mid);
		else
			printf("No solution!\n");

	}

	return 0;

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值