Can you solve this equation?--CSU-ACM2017暑假集训2-二分搜索




Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100; 
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2
100
-4
Sample Output
1.6152
No solution!


double用printf输出时要用%f不是%lf,至少本地运行只能用%f

AC代码:

#include<iostream>
#include<cstdio>
using namespace std;

const double preci=1e-8;

double cal(double a)
{
    return 8*a*a*a*a+7*a*a*a+2*a*a+3*a+6;
}

int main()
{
    int T;scanf("%d",&T);
    while(T--)
    {
        double y;
        scanf("%lf",&y);
        if(y<cal(0)||y>cal(100))
        {
            printf("No solution!\n");
            continue;
        }
        double left=0,right=100;
        double mid;
//        mid=(right+left)/2;
//        cout<<mid<<endl;
        while(right-left>1e-6)
        {
            mid=(right+left)/2;
            if(cal(mid)>y)right=mid;
            else left=mid;
//            cout<<mid<<endl;
        }
        printf("%.4f\n",mid);

    }
}




  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值