hdu 2199_Can you solve this equation?

hdu_2199题目链接

题目描述:
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
Sample Input
2
100
-4
Sample Output
1.6152
No solution!

题意:

给定一个公式是8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,然后从0~~100找答案。如果答案不在这个范围,就输出No solution!

解题思路:

1.因为题目要求,输出结果要保留4位小数,所以结果要精确到第五位小数位。如果从0开始,每次加0.00001去计算是否相等,是很浪费时间。可以看到这个方程是单调的,那么我们就可以使用二分搜索去做。
2.在二分的时候要注意一下二分条件小心超时。

代码:

# include <cstdio>
# include <cmath> 
using namespace std;

double f(double m)  //定义函数求左边的值
{
    return 8*pow(m,4) + 7*pow(m,3) + 2*m*m + 3*m + 6;
}

double two(double y)  //二分
{
    double l = 0.0,r = 100.0;   
    double mid=50.0;  
    while(fabs(f(mid)-y)>1e-5)  //二分条件因为精度要求是4位,所以差值小于0.00001就可以
    {       
        if((f(mid)>y))  
        {  
            r=mid;  
            mid=(l+r)/2;      
        }    
        else if(f(mid)<y)  
        {  
            l=mid;  
            mid=(l+r)/2;                  
        }  
    } 
    return mid;
}

int main()
{
    int T;
    double y;
    scanf("%d",&T);

    while(T--)
    {
        scanf("%lf",&y);
        if(f(0)>y||f(100)<y)  
        {  
            printf("No solution!\n");  
            continue;  
        }
        printf("%.4lf\n",two(y));

    }

    return 0;
} 

如果有疑惑,或指点,请留下你们的意见,一起交流进步。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值