Rails

Rails

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 20000/10000K (Java/Other)
Total Submission(s) : 127   Accepted Submission(s) : 33
Problem Description
There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

Input
The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0.
The last block consists of just one line containing 0.

Output
The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input
  
  
5 1 2 3 4 5 5 4 1 2 3 0 6 6 5 4 3 2 1 0 0

Sample Output
  
  
Yes No Yes
题意:是否能按照题目给出的顺序让火车车厢出栈,每个测试用例之间空一行;
堆栈的简单应用,注意栈顶的变化;
#include <stdio.h>
#include <stdlib.h>
#define mem(x) memset(x,0,sizeof(x))

int q[1002],top,b[1002];
int main()
{
    int n,i,sum;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)
            return 0;
        while(1)
        {
            top=0;
            mem(q);
            mem(b);

            scanf("%d",&b[0]);
            if(b[0]==0)
            {
                break;
                printf("\n");
            }

            for(i=1; i<n; i++)
            {
                scanf("%d",&b[i]);
            }
            sum=0;
            for(i=0; i<n; i++)
            {
                q[top++]=i+1;
                while(q[top-1]==b[sum]&&sum<n)
                {
                    top--;
                    sum++;
                }
            }
            if(top==0)
                printf("Yes\n");
            else
                printf("No\n");
        }
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值