hdu 4300 Clairewd’s message (kmp)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4300



Clairewd’s message

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3426    Accepted Submission(s): 1331


Problem Description
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table.
Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages.
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you.
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.
 

Input
The first line contains only one integer T, which is the number of test cases.
Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.
Hint
Range of test data:
T<= 100 ;
n<= 100000;
 

Output
For each test case, output one line contains the shorest possible complete text.
 

Sample Input
      
      
2 abcdefghijklmnopqrstuvwxyz abcdab qwertyuiopasdfghjklzxcvbnm qwertabcde
 

Sample Output
      
      
abcdabcd qwertabcde
 


第一个Kmp题目=.=

题意:一个转换表,表示'a'转换成第一个字母,'b'转换成第二个字母;一个字符串表示完整的密文+可能不完整原文;输出完整密文+完整原文的字符串

思路:将给出的字符串全部按照转换表转换成另一个字符串,再从原字符串密文最短长度的地方进行kmp匹配查找;



#include <stdio.h>
#include <stdlib.h>
#include <string.h>
char match[26];
char trans[500];
char str[100005];
char p[100005];
int len;
int next[100005];
void getNext()
{
    next[0]=-1;

    int k=-1,j=0;
    while(j<len)
    {
        if(k==-1 || p[k]==p[j])
        {
            k++;
            j++;
            next[j]==k;
        }
        else
            k=next[k];
    }
}
int kmp()
{
    int i,j=0;

    if(len%2==1)  //保证密文长度大于等于给定字符串的一半
        i=len/2+1;
    else
        i=len/2;

    while(i<len&&j<len)
    {
        if(j==-1 || str[i] == p[j])
        {
            j++;
            i++;
        }
        else
            j=next[j];
    }
    return j;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s",match);
        int i;
        for(i=0;i<26;i++) //转换规则
        {
            char ch = match[i];
            trans[ch] = i;
        }
        scanf("%s",str);
        len = strlen(str);
        for(i=0;i<len;i++) //将明文和密文按照转换规则逐一转换
        {
            int temp = trans[str[i]];
            p[i] = temp + 'a';
        }
        getNext();

        int tmp = kmp();

        if(tmp*2 == len)
            printf("%s\n",str);
        else
        {
            int tag = len-tmp; //如果后面缺明文,则用字符串长度减去给出的明文长度算出密文长度,则可得出明文的长度

            printf("%s",str);
            for(i=tmp;i<tag;i++)
                printf("%c",p[i]);
            printf("\n");
        }

    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值