HDU 2952 Counting Sheep

这篇博客详细探讨了HDU 2952 Counting Sheep这个编程竞赛题目。作者介绍了问题背景,解析了题目的核心算法,并分享了解决方案的关键步骤,包括如何有效地进行计数和避免循环中的陷阱。此外,还讨论了可能的优化技巧和常见错误,帮助读者更好地理解和解决此类问题。
摘要由CSDN通过智能技术生成
Problem Description
A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.


Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps A and C are in the same flock.


Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.
 

Input
The first line of input contains a single number T, the number of test cases to follow.

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.
 

Output
For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.

Notes and Constraints
0 < T <= 100
0 < H,W <= 100
 

Sample Input
  
  
2 4 4 #.#. .#.# #.## .#.# 3 5 ###.# ..#.. #.###
 

Sample Output
  
  
6 3
几道较为相似的题,只改S++的位置
#include<iostream>
#include<cstdio>
#include<string>
using namespace std;
int h,w,s;
char map[105][105];
int dx[4]={1,0,-1,0},dy[4]={0,1,0,-1};
void dfs(int x,int y)
{
	int i,nx,ny;
	for(i=0;i<4;i++)
	{
		nx=x+dx[i],ny=y+dy[i];
		if(nx>0&&nx<=h&&ny>0&&ny<=w&&map[nx][ny]=='#')
		{
			map[nx][ny]='.';
			dfs(nx,ny);
		}
	}
}
int main()
{
	int i,j,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&h,&w);
		for(i=1;i<=h;i++)
			for(j=1;j<=w;j++)
				cin>>map[i][j];
			s=0;
		for(i=1;i<=h;i++)
			for(j=1;j<=w;j++)
			{
				if(map[i][j]=='#')
				{
					map[i][j]='.';
					dfs(i,j);
					s++;
				}
			}
			printf("%d\n",s);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值