ACM-搜索之Counting Sheep——hdu2952

Counting Sheep
Problem Description
A while ago I had trouble sleeping. I used to lie awake, staring at the ceiling, for hours and hours. Then one day my grandmother suggested I tried counting sheep after I'd gone to bed. As always when my grandmother suggests things, I decided to try it out. The only problem was, there were no sheep around to be counted when I went to bed.

Creative as I am, that wasn't going to stop me. I sat down and wrote a computer program that made a grid of characters, where # represents a sheep, while . is grass (or whatever you like, just not sheep). To make the counting a little more interesting, I also decided I wanted to count flocks of sheep instead of single sheep. Two sheep are in the same flock if they share a common side (up, down, right or left). Also, if sheep A is in the same flock as sheep B, and sheep B is in the same flock as sheep C, then sheeps A and C are in the same flock.

Now, I've got a new problem. Though counting these sheep actually helps me fall asleep, I find that it is extremely boring. To solve this, I've decided I need another computer program that does the counting for me. Then I'll be able to just start both these programs before I go to bed, and I'll sleep tight until the morning without any disturbances. I need you to write this program for me.

Input
The first line of input contains a single number T, the number of test cases to follow.

Each test case begins with a line containing two numbers, H and W, the height and width of the sheep grid. Then follows H lines, each containing W characters (either # or .), describing that part of the grid.

Output
For each test case, output a line containing a single number, the amount of sheep flock son that grid according to the rules stated in the problem description.

Notes and Constraints
0 < T <= 100
0 < H,W <= 100

Sample Input
2
4 4
#.#.
.#.#
#.##
.#.#
3 5
###.#
..#..
#.###

Sample Output
6

3


题意就是,看看有多少组#,上下左右相连的算同一组,

这道题其实跟Oil Deposits差不多,那道题是八个方向,这道题只有四个方向。

从第一行第一列开始找,每找到一个#,开始以此为起点向四个方向搜索,将所有#变成 .  ,

找到最后就知道总共有多少组了。

Oil Deposits题目:http://blog.csdn.net/lttree/article/details/19908339


代码:

#include <iostream>
using namespace std;
int n,m,dis[4][2]={0,1,1,0,0,-1,-1,0};
char mapp[101][101];

void dfs(int x,int y)
{
    // 遇到 。 则返回
    if(mapp[x][y]=='.') return;
    // 越界则返回
    if(x<0 || y<0 || x>=n || y>=m)  return;
    // 让该点不可以再次走
    mapp[x][y]='.';

    for(int i=0;i<4;++i)
        dfs(x+dis[i][0],y+dis[i][1]);
}

int main()
{
    int num,i,j,sum;
    cin>>num;
    while(num--)
    {
        cin>>n>>m;
        for(i=0;i<n;++i)
            for(j=0;j<m;++j)
                cin>>mapp[i][j];

        // sum记录总数,每找到一个#就向四个方向扩散,并且总数加1
        sum=0;
        for(i=0;i<n;++i)
            for(j=0;j<m;++j)
                if(mapp[i][j]=='#')
                {
                    ++sum;
                    dfs(i,j);
                }

        cout<<sum<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值