hdu 1026 Ignatius and the Princess I

Problem Description
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166's castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166's room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.
 

Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.
 

Output
For each test case, you should output "God please help our poor hero." if Ignatius can't reach the target position, or you should output "It takes n seconds to reach the target position, let me show you the way."(n is the minimum seconds), and tell our hero the whole path. Output a line contains "FINISH" after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.
 

Sample Input
  
  
5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX. 5 6 .XX.1. ..X.2. 2...X. ...XX. XXXXX1 5 6 .XX... ..XX1. 2...X. ...XX. XXXXX.
 

Sample Output
  
  
It takes 13 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) FINISH It takes 14 seconds to reach the target position, let me show you the way. 1s:(0,0)->(1,0) 2s:(1,0)->(1,1) 3s:(1,1)->(2,1) 4s:(2,1)->(2,2) 5s:(2,2)->(2,3) 6s:(2,3)->(1,3) 7s:(1,3)->(1,4) 8s:FIGHT AT (1,4) 9s:FIGHT AT (1,4) 10s:(1,4)->(1,5) 11s:(1,5)->(2,5) 12s:(2,5)->(3,5) 13s:(3,5)->(4,5) 14s:FIGHT AT (4,5) FINISH God please help our poor hero. FINISH
比较经典的搜索,重写一遍还是花了不少时间。
要求从(0,0)到(n-1,m-1)花的时间最小,数字代表到这格时要多花的时间,要求输出路径。
用到了优先队列bfs,先将图转化为点,记录到每点的时间,从终点走向起点,记录每点前驱。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
int f[110][110],n,m;
int to[4][2]={0,1,0,-1,1,0,-1,0};
bool vis[110][110];

struct node
{
    int x,y,t;
    friend bool operator<(node a,node b)
    {
        return a.t>b.t;
    }
};
struct point
{
    int nx,ny;
    char c;
}map[110][110];
int bfs()
{
    int i,j;
    priority_queue<node> q;
    node now,ne;
    now.x=n-1,now.y=m-1;
    if(map[now.x][now.y].c>='1'&&map[now.x][now.y].c<='9')
    {
        now.t=map[now.x][now.y].c-'0';
        f[now.x][now.y]=now.t;
    }
    else
    now.t=0;
    q.push(now);
    while(!q.empty())
    {
        now=q.top();
        q.pop();
        if(now.x==0&&now.y==0)
        return now.t;
        for(i=0;i<4;i++)
        {
            ne.x=now.x+to[i][0];
            ne.y=now.y+to[i][1];
            if(ne.x>=0&&ne.x<n&&ne.y>=0&&ne.y<m&&!vis[ne.x][ne.y]&&map[ne.x][ne.y].c!='X')
            {
                if(map[ne.x][ne.y].c>='1'&&map[ne.x][ne.y].c<='9')
                {
                    ne.t=now.t+map[ne.x][ne.y].c-'0'+1;
                    f[ne.x][ne.y]=map[ne.x][ne.y].c-'0';
                }
                else
                ne.t=now.t+1;
                q.push(ne);
                vis[ne.x][ne.y]=1;
                map[ne.x][ne.y].nx=now.x;
                map[ne.x][ne.y].ny=now.y;
            }
        }
    }
    return -1;
}
int main()
{
    int i,j,cnt,x,y,tx,ty,ok;
    while(~scanf("%d%d",&n,&m))
    {
        for(i=0;i<n;i++)
            for(j=0;j<m;j++)
            {
                scanf(" %c",&map[i][j].c);
                vis[i][j]=f[i][j]=0;
            }
        vis[n-1][m-1]=1;
        ok=bfs();
        if(ok!=-1)
        {
            printf("It takes %d seconds to reach the target position, let me show you the way.\n",ok);
            cnt=1,x=y=0;
            while(cnt!=ok+1)
            {
                printf("%ds:(%d,%d)->(%d,%d)\n",cnt++,x,y,map[x][y].nx,map[x][y].ny);
                for(i=0;i<f[map[x][y].nx][map[x][y].ny];i++)
                    printf("%ds:FIGHT AT (%d,%d)\n",cnt++,map[x][y].nx,map[x][y].ny);
                tx=map[x][y].nx,ty=map[x][y].ny;
                x=tx,y=ty;
            }
        }
        else
        printf("God please help our poor hero.\n");
        printf("FINISH\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值